rMBP HDMI Black Screen

Discussion in 'MacBook Pro' started by Septic, Aug 9, 2012.

  1. Septic macrumors newbie

    Joined:
    Dec 12, 2011
    #1
    Hello,

    I've noticed a "black screen" / "flickering" on the monitor attached to hdmi of the rmbr, I've already tried 3 different monitors and it always happens. For about 2 - 3 sec the screen is black every 40 - 60 minutes.

    I wanted to ask if anybody else is experiencing the same problem?

    Regards
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #2
    Do you use the Integrated Graphics Processor (IGP) or dedicated GPU? Use gfxCardStatus to find out.
     
  3. Septic thread starter macrumors newbie

    Joined:
    Dec 12, 2011
  4. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #4
    What happens if you disable the Automatic Switching and only use the IGP (i), if that is even possible?
     
  5. Septic thread starter macrumors newbie

    Joined:
    Dec 12, 2011
    #5
    That's not possible, all the external displays go black
     
  6. su0301 macrumors newbie

    Joined:
    Jul 25, 2012
    #6
    Another issue with HDMI

    I found a similar but different issue with the HDMI.

    I have a monitor with both HDMI and VGA interfaces. When I connect the monitor to rMBP using HDMI, it works well in the mirror mode (i.e., the monitor and the laptop display the same). But the monitor goes black and keeps flickering if I switch to the extension mode.

    If I use the VGA instead (through thunderbolt to VGA adapter), then the extension mode works well.

    Does this mean the HDMI connection supports only the mirror mode?
     
  7. mgartner0622 macrumors 65816

    mgartner0622

    Joined:
    Jun 6, 2010
    Location:
    Colorado, USA
    #7
    OK, first off, you can't run the external display on the integrated graphics. From what I can tell, the Intel IGP is only connected to the computer's built in display.

    Also, the computer should be able to output in extended or mirrored, no matter what adapter, just as long as you're using the dedicated ATi card and not the Intel IGP. Are you using good quality cables? Ant type of adapters, etc.?
     
  8. Septic thread starter macrumors newbie

    Joined:
    Dec 12, 2011
    #8
    @mgartner0622: you should probably read the question in more detail, it would also help to read all the responses ;)


    The flickering only happens via HDMI.
    Displayport, DVI over DP, VGA over DP, HDMI over DP all work fine

    So su0301, is it constant flickering or is it like with mine every other hour?
     
  9. su0301 macrumors newbie

    Joined:
    Jul 25, 2012
    #9

    With HDMI connection, it is constant flickering (and almost black) after switching to the extension mode, but looks ok in mirror mode.

    In your case, the flickering every other hour was in extension mode or in mirror mode, or both of them?
     
  10. Septic thread starter macrumors newbie

    Joined:
    Dec 12, 2011
    #10
    Extension Mode, did not try the mirroring because it's useless to me
     
  11. dsstao macrumors newbie

    Joined:
    Sep 14, 2010
    #11
    I'm having the same issue

    I can confirm I'm having the same issue: HDMI connected Dell U2412M at 1920x1200 @60Hz. The monitor works fine in extended mode (I never use mirror), except once every few hours, it'll go black for a few seconds. The latest update did not fix it. I'm on OSX 10.8.2.
     
  12. gianspi macrumors newbie

    Joined:
    May 5, 2009
    #12
    Has anyone found a solution?

    My Retina MBP is exhibiting the same issue over HDMI.

    Using a 24" Hanns-G HH251 Monitor via HDMI.
     
  13. THETIMES, Mar 21, 2013
    Last edited: Mar 21, 2013

    THETIMES macrumors newbie

    Joined:
    Feb 15, 2013
    #13
    I have this problem with a PMI hdmi cable and a Samsung LED monitor. I have had other macbook pro retina's and this latest one I own is the only one to do this.

    It's a real problem. I'm surprised this thread doesn't have more posts. Anyone have any info about this?

    It seems to happen right when I am in the middle something like clicking something in Safari, but maybe that's coincidence.

    It happens once or twice a day. A black screen for a couple seconds and everything is perfect again.
     

Share This Page