rMBP internet issue

Discussion in 'MacBook Pro' started by snnow, Aug 23, 2012.

  1. snnow macrumors newbie

    Joined:
    Aug 16, 2012
    #1
    Hi there,

    First of all, I ask you to apologize my bad english, I don't speak fluently.

    I bought a Macbook Pro with Retina display (base model). Everything was working fine and then, suddenly, my internet got strange. After MUCH research and test, I figured out that when I change my Wireless settings to the "g" protocol, it works fine, but when it's on the "n" protocol, the Mac OS X acts weirdly (the internet related apps). The sites doesn't load, then after some time they load and then stop again. It's driving me crazy!! I don't know what to do!

    My modem is a DSL-500B (from D-Link) and the router is the WR1043ND (from TP-Link). Do you guys have any idea? Should I consider returning it? The most strange thing is that on Windows (Boot camp) the internet WORKS LIKE A CHARM!

    Below I'll list everything that I've already tried:
    - Reset SMC and PRAM.
    - Tried to boot in the Recovery HD and use the Safari that has on it.
    - Changed the DNS to Google Public DNS.
    - New location.
    - Deleted the /Library/Preferences/SystemConfiguration folder.
    - Formated (Erased) and made a Clean Install of Mountain Lion (twice).

    None of this worked! Please, someone help me.
     
  2. kjlake macrumors member

    Joined:
    Jul 15, 2010
    #2
    My thoughts are that there is interference that is causing issues when you try to connect at 802.11n speeds. There can be multiple causes for this, including cordless phones, and microwave ovens. While I don't have the same model wireless router, I had similar issues, and found that replacing the router with one that supported both 2.4 GHZ and 5.8GHZ solved my wireless connectivity issue.

    Good luck
     

Share This Page