rMBP Late 2013, Freezing - New Install, EFI Update?

Discussion in 'MacBook Pro' started by rawfuls, Jan 30, 2016.

  1. rawfuls macrumors newbie

    Joined:
    Dec 22, 2012
    #1
    Have a client's rMBP from Late 2013, no liquid damage or physical damage.
    Has an SSD, so failing HDD is just about out of the question.
    Ran Apple's "Extended" Diagnostics via CMD+D on bootup, passed everything (minus battery, but that's expected).

    Basically, it will lock up about once every...15-30 seconds?
    Unknown amount of time, I could be doing nothing and it locks up.
    It's been reinstalled with El Capitan, Mountain Lion, Mavericks, etc.

    I know it's not a hardware issue because it will work just fine (as it's supposed to) when booted into "Safe Mode."

    Searched around, found that this was a very big widespread issue, Apple released an EFI update which was supposed to solve the issue.
    https://support.apple.com/kb/DL1704?viewlocale=en_US&locale=en_US

    Computer has:
    Boot ROM Version: MBP111.0138.B16
    SMC Version: 2.16f68

    Obviously, laptop is well out of warranty, I want to see if I can do anything before deeming it a logic board.

    Thoughts?
    I tried putting it back on to OS X Mavericks, the closest copy I could get was 10.9.5 which was supposed to have the EFI update built in, and then the Apple installers won't let me overwrite the EFI update.
    Can I reflash the EFI?
     
  2. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #2
    If you have the 13" model, the EFI is up to date. It doesn't look like there have been updates for the SMC.

    That's likely correct. So when the OS is reinstalled, is it a completely clean reinstall or is there some software that either remains or is installed after the OS install? If you have a completely clean install and are then having problems with with a lockup every 15-30 seconds, then there's probably some kind of hardware issue with the items that are not loaded in a safe install. If this is the case, if you are near an Apple store, you can call and see if they'll help you - they probably will even if it's no longer under warranty (obviously they would charge if hardware needed to be replaced).

    If you have non-OSX software loaded on the computer, then the problem is likely with that software. You may want to look (while in Safe Mode) in /Library/Logs/DiagnosticReports and see if there files that start with "Kernel" and have the .panic extension. If there are file(s) there, you can post one here and see if anybody can help.

    Also, if you have any kind of devices connected to the computer, try disconnecting them and see if you have the problem. If wifi is being used, you can try disabling it and see if the problem occurs as well.
     
  3. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #3
    Whenever I reinstall, it's a fresh, delete partitions, create new partition, install fresh.
    Sometimes it'll lock up during "Get Started" immediately after the fresh install, so it's all OSX programs, no third-party programs.

    Wireless is off, as I'll have an ethernet patched in, no KPs to report of, just straight lock up and freezing.
    I've called, but Apple wouldn't touch the computer as it's under warranty.
    I'll try my hand at taking it in to the Genius Bar, but suspect the same thing.

    My assumption is that they will want to replace the logic board for their "Flat Rate Repair," since their diagnostics will pass.
     
  4. treekram, Jan 30, 2016
    Last edited: Jan 30, 2016

    treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #4
    I presume you meant to say it's out of warranty. In saying to call Apple, I meant to and should have said to call an Apple Store and see if the Genius Bar folks would be willing to look at it.

    The Genius Bar folks do have more comprehensive diagnostics software so it could turn up something that the regular diagnostics does not turn up. You mentioned something about the battery - is there a problem with the battery? Battery issues can cause problems and is probably something that the Genius Bar folks can help with.

    EDIT: Did you run the diagnostics in extended mode?
     
  5. rawfuls, Jan 30, 2016
    Last edited: Jan 30, 2016

    rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #5
    I can give Apple a try at another date as they're not too close, thanks.

    Besides the battery just being old and holding a shorter than usual charge, no.

    EDIT: Don't know how to run the ADT in extended mode because it'll automatically run 2-3 minutes, then give me reference codes.
     
  6. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
    #6
    I do not see extended test available in ADT. Extended is available in AHT, but AHT is not the correct test software for your year Mac.
     
  7. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #7
    Sorry about that - it looks like your computer would have Diagnostics, not Hardware Test (the switch-over was in 2013) and it looks like Diagnostics doesn't have the extended test. The extended test would do a more comprehensive memory test, although it wouldn't help your situation a lot because you can't change the RAM anyway. So just the battery issue is coming up? What reference code comes up? A list of the reference codes are in:

    https://support.apple.com/en-us/HT203747

    I think if it's a code other than PPT002 or PPT003, perhaps the battery is causing the problems.

    It's kind of suggested as a catch-all, but you don't have anything to lose in resetting the NVRAM and SMC.

    https://support.apple.com/en-us/HT204063

    https://support.apple.com/en-us/HT201295

    (CoastalOR, your post came in as I was finishing this up.)
     
  8. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #8
    It's a PPT004, just acting abnormally.

    I've ran my own personal diagnostics on it, Eurosoft PC-Check, which is what we use exclusively at work and it all checked out perfectly.
    I've ran memtest86+, same thing.

    I'm almost 100% set on that the BOOT ROM (what I would think is similar to a BIOS chip?) was flashed incorrectly, leaving remnants of the previous EFI on, which is still causing the lock-up.

    I may try and take it to the Genius Bar and see what they can do, but I'm pretty sure they'll shrug me off and mention the $450/whatever surcharge for a flat rate repair, and "get me going" again.

    Sigh.
     
  9. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #9
    In doing a search on the Internet, a lot of people with MacBook Air's get PPT004 and there is no problem - so ignore that. There are several instances where people with an MBP, and the majority with a 2013 MBP, that had this code and had similar problems to what you are seeing. Unfortunately, none that I saw had a resolution or a cause of the problem. Once such instance on this forum is:

    http://forums.macrumors.com/threads...g-the-macbook-unusable.1950152/#post-22460493

    I only spent a few minutes looking so perhaps a more persistent search will turn up better results. Either there is a battery problem that can cause the problem you're seeing or similar problems, or there is another problem where one of the symptoms is the PPT004 code.

    If you think the EFI flash went wrong, Apple does have a way to re-flash the BIOS. I haven't used this so I can't say if it works or not.

    https://support.apple.com/en-us/HT201692

    I know you're cynical about what they're going to say at the Apple Store, but I don't know that there's a better alternative at this point (I don't think it's a EFI issue, but since Apple has something available to do it, it's worth a try).
     
  10. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #10
    I'm pretty sure PPT004 is just flagging the battery to be replaced because it's not hitting it's "80%" life, so now it wants to be replaced.
    Had the same issue on my MacBook Pro (pre-retina).

    RE: EFI Flash, I might have to give this a try, I'll see the timeline my client is on and see if I can stop by an Apple store sometime this week.
    I'll be honest, I am a bit cynical about Apple and their out-of-warranty support, but that's because sometimes I've dealt with them more times than I have wished.

    I AM an avid Apple user for mobile and portable solutions; still prefer a power house Windows box.
     
  11. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #11
    If you look at https://support.apple.com/en-us/HT203747 you will see different diagnostic result codes. There are some for battery near-end-of-life issues. The PPT004 is not one of them. On your non-Retina MBP, since it must have been the Apple Hardware Test (as I made the mistake earlier), I don't know how you that you had the "same issue" since the codes are different from the Apple Diagnostics and the "battery requires service" wasn't one of the condition descriptions. What I'm saying is that you could have a battery issue outside of the typical battery is-nearing-end-of-life issues, a possibility you seem to be completely discounting. Recent MBP's require good battery health to function properly even with AC power. OSX will start to intervene in computer operation if it senses that the battery is not in good health, even with AC power. That is consistent with the computer working in safe mode but not with full OSX. Will your client's computer work properly with a new battery? I don't know. But I wouldn't rule it out either.

    You've run the Apple Diagnostics, memtest and diagnostics that seems to be for PC's (in Bootcamp or booting from USB stick?). The only problem that comes up with is the battery issue, despite the fact that you have a major and consistent problem - something that the diagnostics software are best equipped to find. You think it's the EFI. It certainly could be. But the issue that you cite first came to light in 2013. Has the computer been having these issues since that time? Perhaps the 2013 EFI update fixed that issue only to be broken again with a botched EFI upgrade. That's just not likely because you cannot revert the EFI back to an earlier version. The latest EFI update was a security update so perhaps somebody exploited a security hole previous to the latest update to sabotage your client's computer. Possible, but not likely. In any case you have the information to reflash the EFI so that's something you can try.
     
  12. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #12
    Good thoughts, I may have to try another battery and give it a shot.
    I figured it would be an end-of-life as it's lifespan seems to be very short (only a few hours), as it was running on power for the first round of diagnostics until it failed; that's when I figured it was just end-of-life.

    The diagnostics you listed are all DOS level diagnostics, you boot into them and don't require an operating system.

    The EFI update is below:
    https://support.apple.com/kb/dl1704?locale=en_US

    There IS one also for security, but this one peaks my interest.
     
  13. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #13
    So the thread I mentioned in post #9 where somebody else was getting the PPT004 result code has a resolution - dust. That OP took his MBP to an Apple store and they cleaned out the dust and now it apparently works fine. I've asked a question as to whether or not PPT004 is still happening. For me, if it's somebody else's computer, I wouldn't try to clean it out myself, but if you do, you'd need the Pentalobe screwdriver to open it up.
    https://www.ifixit.com/Store/Tools/P5-Pentalobe-Screwdriver-Retina-MacBook-Pro-and-Air/IF145-090-3

    Chances are that dust isn't the cause here, but hey, it's easy and cheap so who knows?
     
  14. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #14
    Thanks for doing the research!
    One of my procedures is to actually open up the computer (or laptop) and dust it out as well as cleaning it if necessary (goop, etc) internally and externally.
    Unless I may have missed a spot, I don't particularly think it'd be a dust issue.

    I do wonder if it was a connection issue with one of the connectors, which I think would be a bit more plausible.
     
  15. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #15
    Tried running EFI updater a few more times, kept saying it'd fail, but one time it ran then crashed/shut down; figured it was the battery.
    Tried it this morning, and it seems to work.

    Turned it back on after about a day of cold boot, didn't seem to really hiccup; almost as if the problem just vanished.
    Regardless, opened the case up, cleaned everything up (wasn't even that dirty), redid most/if not all connections, and no issues since.

    I'm not quite sure what to chalk this up as, I got to the Apple store this morning (given, without a reservation) and the wait was 6.5 hours long.

    I figure, if the client brings it back, I'll schedule an appt and see what they say.
    For now, I'm just going to go with an irregularity bug, and somehow a 'failed' EFI update fixed it.
     
  16. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #16
    If the problem is indeed cleared up, what would be good to know is if the PPT004 condition still exists. The OP in the other post with the PPT004 issue hasn't replied. If the PPT004 disappears when other non-battery problems are fixed, or the PPT004 problem is something that doesn't always cause observable problems (as is the case with the Macbook Air) would be useful information.
     
  17. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #17
    Oddly enough, holding down D while booting doesn't launch diagnostics.
    Just a blank, black screen.
    Weird, right?
     
  18. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #18
    Strange indeed. Another reason to go visit the nearest Genius Bar (but I wouldn't be pleased if they told me it required a logic board replacement to fix ;)).
     
  19. rawfuls thread starter macrumors newbie

    Joined:
    Dec 22, 2012
    #19
    Laptop was returned to client due to timeline issues, if client brings it back then there'll be a visit to the Genius Bar, with an appointment.

    I figure they will be able to run it through it's paces on a daily basis as I wouldn't be able to.
    If they find an issue, I'll be taking a deeper look.
     

Share This Page