rMBP Mountain Lion wallpaper resets every startup

kmai

macrumors newbie
Original poster
Jul 21, 2012
4
0
This is a relatively minor thing but it's been frustrating. I have a retina MBP running Mountain Lion and it won't keep any wallpaper I set. Every time the computer boots, it's been set back to the "default" wallpaper (the galaxy). When I go into System Prefs -> Desktop, it still shows as though it's set on the wallpaper I selected, but the actual wallpaper on the desktop is always the default galaxy. I reset it back to the one I want, and it's fine until the next time I shut down and reboot, then it's back to the galaxy, every time.

Anyone seen this before? If so, does anyone know a simple way to fix it? (Google is failing me.)

PS: I did go into the Desktop Pictures folder and I renamed "Galaxy.jpg" and then added a copy of the image I want and titled it "Galaxy.jpg" instead. This "worked", but it's not a genuine fix for the issue, so if anyone can shed any light on how to fix the actual problem, I'd be extremely appreciative!
 
Last edited:

teerexx52

macrumors 68000
May 1, 2005
1,973
98
Florida West Coast
This is a relatively minor thing but it's been frustrating. I have a retina MBP running Mountain Lion and it won't keep any wallpaper I set. Every time the computer boots, it's been set back to the "default" wallpaper (the galaxy). When I go into System Prefs -> Desktop, it still shows as though it's set on the wallpaper I selected, but the actual wallpaper on the desktop is always the default galaxy. I reset it back to the one I want, and it's fine until the next time I shut down and reboot, then it's back to the galaxy, every time.

Anyone seen this before? If so, does anyone know a simple way to fix it? (Google is failing me.)

PS: I did go into the Desktop Pictures folder and I renamed "Galaxy.jpg" and then added a copy of the image I want and titled it "Galaxy.jpg" instead. This "worked", but it's not a genuine fix for the issue, so if anyone can shed any light on how to fix the actual problem, I'd be extremely appreciative!
I was able to get around this problem by doing the following:

1. Select your wall paper from your choices in the Desktop folder.
2. Then move your cursor down to solid colors and just click on it
3. Close system preferences and restart.
4. Problem solved?
 

juicywaterhouse

macrumors member
Dec 30, 2010
54
0
Southern California
I was able to get around this problem by doing the following:

1. Select your wall paper from your choices in the Desktop folder.
2. Then move your cursor down to solid colors and just click on it
3. Close system preferences and restart.
4. Problem solved?
iPad and a Mini huh? I have the same set up as you sans the mini ... I imagine it's hard dealing with that screen.