rMBP needs to be plugged in multiple times in order to begin charging.

Discussion in 'MacBook Pro' started by PCWebbJR, Oct 24, 2012.

  1. PCWebbJR macrumors member

    Joined:
    Jun 20, 2012
    Location:
    Chicago, Illinois
    #1
    I came across a weird problem over the last two days. I noticed that, occasionally, when I plug in my charger no light comes on and my computer does not charge. However, on every occasion, when I unplug and plug it back in it immediately turns on and begins charging. It's happened 3 or 4 times now, where I plug it in and then have to re-plug it in for it to begin charging. Anyone heard of a cause or is having similar problems?

    15in rMBP / 2.6GHz / 16GB / 256 SSD
     
  2. xxcysxx macrumors 6502

    Joined:
    Oct 12, 2011
    #2
    If you mean the plug that magnetically attach to the laptop then perhaps there might be some dirt or debris on the pins or contacts. Use a toothbrush on it and see if it help clears it up.
     
  3. PCWebbJR thread starter macrumors member

    Joined:
    Jun 20, 2012
    Location:
    Chicago, Illinois
    #3
    Both the plug and the charger are clean, no pins appear to be stuck. So I'm not sure what's going on. It's intermittent.
     
  4. naujoks macrumors 6502

    naujoks

    Joined:
    Jul 6, 2008
    Location:
    London, UK
  5. glhughes macrumors regular

    Joined:
    Jul 4, 2009
    #6
    I have this problem on my 2010 MB Air. It's the magsafe adapter. In my case, it got bad enough that I had the adapter replaced, after which it worked perfectly for another 6 months. The second adapter is starting to exhibit this behavior now too. No idea what causes it as the head of the adapter looks perfectly fine.
     
  6. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #7
    Just bought my 13 rmbp a few days ago and it does the same thing! Woke up this morning with a dead computer! I think it is the charger and not the computer cause my old charger with a magsafe adapter hasn't done it once!
     
  7. tmanto02 macrumors 65816

    tmanto02

    Joined:
    Jun 5, 2011
    Location:
    Australia
    #8
    actually no I take that back - same thing happens with my old charger
     

Share This Page