rMBP over-zoomed in on game... can't change resolution

Discussion in 'MacBook Pro' started by cookcfc, Nov 9, 2012.

  1. cookcfc macrumors newbie

    Joined:
    Nov 9, 2012
    #1
    I'm trying to play a somewhat older game on my rMBP (Empire at War). I managed to use it yesterday and I changed the resolution to whatever the highest one was. Now when I open it, it readjusts so that it's just expanded outside of the reach of the screen. Like it's really zoomed in on the bottom left corner. I think it's because my mac lowers its resolution when it opens it or scales down, but the app is still set in really high resolution (but doesn't recognize that the display can actually fit it). Any ideas?
     
  2. cookcfc thread starter macrumors newbie

    Joined:
    Nov 9, 2012
    #2
    Bump! I think any way to stop auto-resolution-correction would work perfectly... if anyone knows of some app...
     
  3. emori, Dec 28, 2012
    Last edited: Dec 28, 2012

    emori macrumors newbie

    Joined:
    Dec 28, 2012
    Location:
    São Paulo, Brazil
    #3
    Does anyone have the solution to this?

    It's annoying, I can't play any game in fullscreen on OS X.

    Other users having the same problem, but with a totally different setup:
    http://www.orderedbytes.com/forum/viewtopic.php?p=7712&sid=4bf5232b84ed7c51b020264f45cf4e33
    http://forums.civfanatics.com/showthread.php?t=471270
    http://www.neogaf.com/forum/showthread.php?t=489433
    https://discussions.apple.com/thread/4191657?start=0&tstart=0

    I just have installed Steam and downloaded games like Psychonauts (horrible port by the way, had to transfer my savegame to the Windows version to be able to play) and Trine. You can play only if you set the resolution to 1440x900, if you try to use 2880x1800 you will be able to see only the lower left quarter of the screen.

    Users report they solved this by turning off auto GPU switching. Still not the ideal solution.
     
  4. Dyno-Mike macrumors regular

    Joined:
    Aug 19, 2012
    Location:
    United Kingdom
    #4
    I always play games on osx at 1440x900. It uses pixel doubling and looks better than when using the same res under boot camp.
    Why do you not like to use it at this resolution?
     
  5. DTKblaster macrumors member

    Joined:
    Aug 3, 2012
    #5
    I noticed this happening when launching classic WoW (patch 1.12.1), the fix was simply to force either integrated graphics or dedicated graphics using gfxcardstatus. Leaving it on dynamic switching results in the zooming in thing.
     
  6. sireShonBohn macrumors regular

    Joined:
    Jun 18, 2012
    #6

    Civ 5 supports retina. Maybe you could get the new version.
     
  7. emori macrumors newbie

    Joined:
    Dec 28, 2012
    Location:
    São Paulo, Brazil
    #7
    Why watch movies at 1080p when I can go to YouTube watch at 240p?

    Scaling still have bugs on OS X, I hope Apple fixes these rMBP bugs soon. They seem more concerned about releasing the next wave, one year cycles seems to be too fast for them to keep up.
     

Share This Page