rmbp overheats when windows 7 gaming

Discussion in 'MacBook Pro' started by frocco, Dec 18, 2012.

  1. frocco macrumors 6502

    frocco

    Joined:
    Jan 27, 2009
    #1
    When I am gaming on Windows 7, I do not hear the fans at all.
    After a while, the game starts to act funny because of the heat.

    I installed istat on OSX and can change the fans speed, is this normal or is something wrong with my mbp?
     
  2. makaveli559m macrumors 6502

    Joined:
    Apr 30, 2012
    #2
    I use a program called LubbosFanControl on the Windows side, iStat doesnt allow control of fan speeds.
     
  3. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #3
    This is completely normal, don't mess with your fans. Your computer will also automatically shut down if there is any danger to the unit itself, gaming is a graphics/memory intensive task and the computer needs to keep itself cool.
     
  4. BlaqkAudio macrumors 6502

    Joined:
    Jun 24, 2008
    Location:
    New York
    #4
    It's a problem with Boot Camp's use of the discrete GPU for everything, even just sitting idle. The only way to overcome the issue is to either undervolt the CPU or set your fans higher to compensate for the higher heat.
     
  5. Daniel L macrumors 6502

    Joined:
    Sep 15, 2009
    #5
    Reset your SMC. I have to do that every time I reboot into Windows to do some gaming.
     
  6. bill-p macrumors 65816

    Joined:
    Jul 23, 2011
    #6
    If you do not hear the fans at all, chances are you have been struck by the EFI bug. Here's more information:
    http://forums.macrumors.com/showthread.php?t=1452267

    Only fix so far, as suggested above, is to reset SMC.
     
  7. frocco thread starter macrumors 6502

    frocco

    Joined:
    Jan 27, 2009
    #7
    Thanks for the info, it is not very encouraging having to reset 8+ times.
    I still am within my return period, and was thinking of getting an iMac.
    But I like the option of using my RMBP on the couch.
     
  8. MCAsan macrumors 601

    MCAsan

    Joined:
    Jul 9, 2012
    Location:
    Atlanta
    #8
    Stop using Windows. That should not be too big a sacrifice. ;)
     
  9. Dyno-Mike macrumors regular

    Joined:
    Aug 19, 2012
    Location:
    United Kingdom
    #9
    Why do you need to that?
     
  10. mrbigglessworth macrumors member

    Joined:
    Dec 5, 2012
    #10
    This kind of comment is not helpful at all to the situation.


    Its the same type of remark a few years back when someone has a minor windows issue and the response is to use Linux instead. It helps noone and you aren't smart nor funny for saying it. People have a valid need to use Windows and under most circumstances with bootcamp, Windows seems to run perfectly fine.
     
  11. Daniel L macrumors 6502

    Joined:
    Sep 15, 2009
    #11
    I don't know what it is but if I don't do that I'll get terrible frame rates. It seems like the SMC won't let the laptop go into high speed mode so everything just goes slower. 20 FPS vs 100 FPS. However, when it's in "slow" mode the laptop is cooler and the fans aren't on as loud.
     
  12. Dyno-Mike macrumors regular

    Joined:
    Aug 19, 2012
    Location:
    United Kingdom
    #12
    That must be so frustrating! Im lucky in that Ive never had the bug.

    Have you tried disabling Turbo on the CPU in bootcamp and see if the bug appears when its disabled?
     

Share This Page