Resolved rMBP SMC won't update

Discussion in 'MacBook Pro' started by reery, Mar 18, 2013.

  1. reery, Mar 18, 2013
    Last edited: Mar 18, 2013

    reery macrumors regular

    reery

    Joined:
    Sep 18, 2012
    #1
    Hi there,

    my SMC version is 2.3f32 for the rMBP mid 2012. When I try to update to 1.1 or 2.3f35 it updates well but after the reboot it still shows that I'm on f32 and not f35. Also App Store still wants to update SMC 1.1.

    What happened here? :(
     
  2. Asuriyan macrumors 6502a

    Joined:
    Feb 4, 2013
    Location:
    Indiana
    #2
    Do a reset on your SMC and PRAM before updating and see what happens.

    Did it update to 10.8.3 succesfully?
     
  3. reery thread starter macrumors regular

    reery

    Joined:
    Sep 18, 2012
    #3
    Yeah update to 10.8.3 was successful.

    Resetting SMC didn't help but resetting NV/PRAM helped!

    So it's solved. Thank you very much!
     
  4. crowbar77 macrumors newbie

    Joined:
    Nov 2, 2012
    #4
    Had this problem too, thanks guys. Get your **** together apple.
     
  5. crowbar77 macrumors newbie

    Joined:
    Nov 2, 2012
  6. 4np macrumors 6502a

    4np

    Joined:
    Feb 23, 2005
    Location:
    The Netherlands
    #6
    I have the same issue here. I am on a Retina MacBook Pro (MacBookPro10,1) which is kept on 10.7 by the company's IT department. It is running Sophos AV and Sophos SafeGuard (disk encryption) and we authenticate via Active Directory.

    The SMC 1.1 update keeps popping up in Software Update, even though I have installed it about 5 times (according to System Preferences -> Software Update -> Installed Software) already. The SMC firmware remains at 2.3f32 while it should be 2.3f35 after the update. I tried resetting SMC as well as NV/PRAM without any luck...

    My guess is that Sophos' SafeGuard disk encryption is somehow messing things up as you have to enter your credentials on boot do be able to use the 'disk'. Even though the Sophos forums said it should be possible...

    Anybody got a clue?
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    I wouldn't be surprised. I know that since it's a company-owned Mac, you probably don't have a choice, but I recommend avoiding Sophos, as it can actually increase a Mac's vulnerability, as described here and here. 3rd party antivirus apps are not needed to keep a Mac malware-free, as long as the user practices safe computing, as described in the following link.
     
  8. crowbar77 macrumors newbie

    Joined:
    Nov 2, 2012
    #8
    Ended up taking it into the apple store, spent 1.5 hours with a genius mostly redoing what I already tried. Even tried installing over a network drive that had 10.8.2, no luck. They ended up keeping it and going to let me know, my hopes aren't to high though. :rolleyes: Its rare but have found a few other posts with this happening, all the way back to 2010.
     

Share This Page