rMBP+Thunderbolt Display Issues

Discussion in 'MacBook Pro' started by sevimli, Aug 30, 2012.

  1. sevimli macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #1
    Hello everyone,

    Have a base model MBPR that I ordered recently, which came factory installed Mountain Lion on it. I did all the updates for the OSX.

    I've been having some problem while my Thunderbolt Display plugged in:

    I (almost) always use my rMBP in clamshell mode at home, I get everything right on the TB display. But if I want to go back to my rMBP screen, I don't get anything, just a black screen (no backlight etc.). Also plugging TB display back won't work, it does NOT power on at all. So I have to do a hard reset whenever I have this problem.

    Occasionally I use AirDisplay but it shouldn't be a problem here.

    Thanks for the time/comments...
     
  2. sevimli thread starter macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #2
    Today I started to get sleeping/wake-up issues: BT keyboard or magic trackpad cannot wake up the rMBP with TB display attached. :confused:
     
  3. eron macrumors 6502

    Joined:
    Dec 2, 2008
    #3
    Press Command 1 to enable display mirroring. Give that a shot.
     
  4. mzjin macrumors 6502

    mzjin

    Joined:
    Oct 28, 2011
    #4
    I know there's a lot of issues right now in Mountain Lion when it comes to Thunderbolt displays, so you may just have to be patient for 10.8.2 or 10.8.3 etc
     
  5. sevimli thread starter macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #5
    I will try this for sure. Would Command+2 disables the mirroring?


    That's true and I don't understand why they weren't addressed in 10.8.1. :confused:
     
  6. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #6
    for some reason if you plug a display into the TB port you can't sleep or suspend your rMBP in any way. If a screen saver comes on it will lock in SS mode and not let you login...if you sleep it will crash upon wake or lock all of your applications up. I have started unplugging any and all displays before putting it to sleep and waking it before plugging in and I haven't had any issues. Unfortunately that means clamshell mode will be plagued with issues.

    Hopefully this will be fixed soon because it is really annoying!!
     
  7. sevimli thread starter macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #7
    Command+2 won't response either. :(

    Just recently I started to get kernel panics. It sleeps and after waking it up it responses normally 2 or 3 seconds and kernel panic...

    Do you think taking it to the Apple Store would be any good?

    Here is the error I got last time:

     
  8. andymac2210 macrumors regular

    Joined:
    Jul 18, 2011
    #8
    You might as well send the report to apple, whether or not they'll do anything about it is anyones guess.
    I remember similar issue with external displays from 10.6.8 that never got resolved even in Lion.

    Maybe it's the same thing.

    After the mark has spent their money, they're out.
     
  9. sevimli thread starter macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #9
    I always send error reports to the Apple.

    I was using my 23" ACD without any problems on Late 2010 MBA.

    Recently purchased this TB display hoping to get same satisfaction, i guess I was wrong this time.
     
  10. iAppl3Fan macrumors 6502a

    iAppl3Fan

    Joined:
    Sep 8, 2011
    #10
    Do a complete format and reinstall on your RMBP. It will fix your problem. I don't know why but that's how I solved it.
     
  11. sevimli thread starter macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #11
    You had the same problems? Actually I was even planning to try Mac OS X Lion.

    Did you use your recovery partition for the fresh install?

    This is just so annoying after spending this amount of money... :rolleyes:
     
  12. iAppl3Fan macrumors 6502a

    iAppl3Fan

    Joined:
    Sep 8, 2011
    #12
    How do you use the recover partition for the fresh install? Does that mean it installs locally?

    Actually I just did a fresh install via Internet Recovery. It solved all my problems being in clamshell, plug-in, and un-plug from TBD as well.
     
  13. sevimli thread starter macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #13

    I don't know, I was just asking how did you perform the fresh install.

    I will give your method a try. Did you use the timemachine backup to restore after the fresh install or you did re-install everything manually?

    Thanks!
     
  14. FuNGi macrumors 65816

    FuNGi

    Joined:
    Feb 26, 2010
    Location:
    California
    #14
    This reminds me of the giant headache allot of people experienced when using the newly introduced Thunderbolt ports with the mini-display port 24" ACD's. THere was a super annoying random flickering of the screen. There was a huge thread on Apple's forum's and a long period of APple denying there was an issue. FInally APple admitted there was an issue and pushed out an EFI update that solved it. I think it took over a year. So just sit tight buddy.
     
  15. iAppl3Fan macrumors 6502a

    iAppl3Fan

    Joined:
    Sep 8, 2011
    #15
    I did everything manually just to be safe. I have a Time Capsule that does regular backups but never really use it.
     
  16. sevimli thread starter macrumors 6502a

    sevimli

    Joined:
    Jun 26, 2007
    Location:
    ChiTown
    #16
    THANK YOU SO MUCH! It worked! I am not getting any kernel panics or other wake/sleep issues any more!

    Today is day 2, I will update here if I experience any problem.
     
  17. iAppl3Fan macrumors 6502a

    iAppl3Fan

    Joined:
    Sep 8, 2011
    #17
    Not a problem!
     

Share This Page