rMBP Thunderbolt to VGA Problem

Discussion in 'MacBook Pro' started by EltonT, Aug 17, 2012.

  1. EltonT macrumors member

    EltonT

    Joined:
    Oct 23, 2010
    #1
    I had a mini display port to VGA adapter from my old 2010 mbp which worked perfectly with displays and projectors during presentations but sticking the adapter into my new rMBP doesn't work, there isn't a signal going through and the screen only flashes blue when I unplug it.

    Note: I bought this off amazon for about $15
     
  2. kimovski macrumors regular

    Joined:
    Mar 22, 2011
    Location:
    Macau
    #2
    Did you use gfxcardstatus for saving battery? You swicth to GT650M in order to use the vga adapter to output.
     
  3. EltonT thread starter macrumors member

    EltonT

    Joined:
    Oct 23, 2010
    #3
    Good point, didn't realize that could be a problem as my previous mbp was a 13", I'll try putting it in discrete only mode and report back with results.

    Thanks.
     
  4. specik macrumors 6502

    specik

    Joined:
    Jun 30, 2012
    Location:
    Brooklyn, NY
    #4
    Another thing to consider is that sometimes those cheap, third-party adapters do not work very well. If you're still having problems, I'd suggest buying the Mini-DisplayPort to VGA adapter from the Apple Online Store. Thunderbolt ports are backwards compatible with Mini-DisplayPort peripherals.
     
  5. EltonT thread starter macrumors member

    EltonT

    Joined:
    Oct 23, 2010
    #5
    I switched to discrete mode and it worked right away :cool:

    Thank you Kimovski
     
  6. paranoiarock macrumors newbie

    Joined:
    Nov 25, 2013
    #6
    Thunderbolt to VGA

    I'm having the same problem, the thunderbolt to via adapter does not work and the monitor as no signal. I have a MBP 13". Can you help me on this?

    Thanks in advance.
     
  7. kimovski macrumors regular

    Joined:
    Mar 22, 2011
    Location:
    Macau
    #7
    Try remove the gfxcardstatus to see what happens.
     

Share This Page