rMBP Thunderbolt to VGA Problem

EltonT

macrumors member
Original poster
Oct 23, 2010
83
12
I had a mini display port to VGA adapter from my old 2010 mbp which worked perfectly with displays and projectors during presentations but sticking the adapter into my new rMBP doesn't work, there isn't a signal going through and the screen only flashes blue when I unplug it.

Note: I bought this off amazon for about $15
 

kimovski

macrumors regular
Mar 22, 2011
119
2
Macau
Did you use gfxcardstatus for saving battery? You swicth to GT650M in order to use the vga adapter to output.
 

EltonT

macrumors member
Original poster
Oct 23, 2010
83
12
Did you use gfxcardstatus for saving battery? You swicth to GT650M in order to use the vga adapter to output.
Good point, didn't realize that could be a problem as my previous mbp was a 13", I'll try putting it in discrete only mode and report back with results.

Thanks.
 

specik

macrumors 6502
Jun 30, 2012
291
52
Brooklyn, NY
Another thing to consider is that sometimes those cheap, third-party adapters do not work very well. If you're still having problems, I'd suggest buying the Mini-DisplayPort to VGA adapter from the Apple Online Store. Thunderbolt ports are backwards compatible with Mini-DisplayPort peripherals.
 

EltonT

macrumors member
Original poster
Oct 23, 2010
83
12
I switched to discrete mode and it worked right away :cool:

Thank you Kimovski
 

paranoiarock

macrumors newbie
Nov 25, 2013
1
0
Thunderbolt to VGA

Did you use gfxcardstatus for saving battery? You swicth to GT650M in order to use the vga adapter to output.
I'm having the same problem, the thunderbolt to via adapter does not work and the monitor as no signal. I have a MBP 13". Can you help me on this?

Thanks in advance.