rMBP UI lag temporary fix

Discussion in 'MacBook Pro' started by TibookAktive, Aug 6, 2012.

  1. TibookAktive macrumors member

    Joined:
    May 27, 2010
    #1
    I'm running a scaled resolution (the one that is 1 notch smaller than default in the preferences - think 1680x1050?) and was having pretty bad lag or "jittery-ness" when using Mission Control under mountain lion.

    I found a tip when browsing the Apple Discussion forums that drastically improved/removed any lag that I had and made all ML gui animations perfectly smooth.

    Apparantly there's a quirk with the Intel driver that needs fixing meaning its not transitioning between the two graphic chips very smoothly, so if you go into your Energy Saver settings (in system prefs) and uncheck the 'Use automatic graphic switching, then it always uses the high-end chip rather than constantly switching between the two. Obviously not ideal and would only recommend if plugged into the mains as sure it drains the battery - but as a temporary fix my rMBP is now running smooth as can be!

    Hope this helps.

    Richard.
     
  2. Drask macrumors regular

    Joined:
    Feb 3, 2012
    #2
    I found another way, though my rMBP only lags when switching desktops by the end of the transition (like the last .5 secs) at 1920x1200. Not a big deal but not as smooth as 1440x900 or 1650x1050.

    One thing you can do is auto-hide the dock, this works perfectly but I like to see my dock all times, so just set your dock to the left or the right NOT the bottom, even when the intel 4000 chip is on at 1920x1200 is smooth as my 2011 iMac.

    Hope this helps.
     

Share This Page