rmbp waking up issue

Discussion in 'MacBook Pro' started by gbit, Oct 14, 2012.

  1. gbit macrumors member

    Joined:
    Aug 20, 2012
    #1
    hi
    if i close my lid on my rmbp and wait a while with waking up it takes between 2 and 10 secounds before i can enter my password
    before that i cant even mouse the mouse cursor or enter anything
    is that normal? is there a way to fix that?
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Seems to be normal, there's been a few threads on this and mine does the same thing. I'd not worry about it, especially if the laptop does not exhibit any other problems.
     
  3. gbit thread starter macrumors member

    Joined:
    Aug 20, 2012
    #3
    i dont worry about it but wtf? windows loads instant! before the lid is open the os is ready!
     
  4. AirThis macrumors 6502a

    Joined:
    Mar 6, 2012
    #4
    Same issue as OP. But it doesn't bother me that much. The rest of the experience is so smooth that it's just a microscopic glitch within the vastness of the universe.
     
  5. rrm998 macrumors regular

    rrm998

    Joined:
    Jun 15, 2012
    Location:
    Houston, TX USA
    #5
    Before buying a rMBP, I tried a friend's 2011 MBA for a week. I noticed that the Air was ready to go by the time I finished opening the lid when waking from sleep. For the rMBP, it's definitely not that fast. A 3 second wake up isn't uncommon for me but sometimes it can be longer. Sometimes the screen flashes blue before showing the desktop.
     
  6. gbit thread starter macrumors member

    Joined:
    Aug 20, 2012
  7. AeroUK macrumors 6502

    Joined:
    Jan 6, 2008
    Location:
    New York
    #7
    Same here! Takes around 3 seconds to wake up and be responsive. Can they fix it with a firmware update?
     
  8. skitzogreg macrumors 6502

    skitzogreg

    Joined:
    Oct 31, 2007
    Location:
    Arkansas
    #8
    Have you tried an SMC reset? Repaired disk permissions? You could have something that's slowing down the startup, but this is only a guess and carries no actual evidence. Try disabling always-on apps such as Dropbox, caffeine, etc., to see if that fixes the issue.
     
  9. agaskew macrumors 6502

    Joined:
    Dec 3, 2009
    #9
    Have you switched off Power Nap?

    By default the rMBP does this deliberately - thats how you get up to 30 days standby time. You can sacrifice that and have faster wake up times.

    Or look here
     
  10. SchuettS macrumors 6502

    Joined:
    Dec 4, 2008
    #10
    Mine starts and wakes up instantly with powernap enabled. Shutting down takes 20 secs, don't know what's going on there.
     
  11. mcb001982 macrumors regular

    Joined:
    May 27, 2008
    Location:
    Manhattan NY
    #11
    This is the only issue I'm having too with my rMBP and it is a little annoying but none the less I can live with it.


    I'm going to try this tonight as my use is very similar to yours - thanks for the tip!!
     
  12. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #12
    Great info--thanks. I had noticed this too but didn't really give it much thought since it is of little consequence for me--but nice to know. :)
     
  13. DJTJ macrumors regular

    Joined:
    May 3, 2005
    #13
    i too have the same issue... small and stupid but drives me crazy
     
  14. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
  15. WPerry66 macrumors newbie

    Joined:
    Apr 8, 2010
    #15
    I followed the instructions in your link, and it worked great.

    However, rather than set it to the 86400 the author called for I changed it to 43200 seconds (six hours).

    When I came home after being out all morning the rMBP sprang to life immediately. No lag, and the arrow pointer didn't disappear. Thanks again!
     
  16. bobr1952 macrumors 68020

    bobr1952

    Joined:
    Jan 21, 2008
    Location:
    Melbourne, FL
    #16
    Seems it is definitely a battery saving feature as I have noticed there is no lag in start up when you sleep your rMBP connected to power.
     
  17. khanable macrumors newbie

    Joined:
    Aug 21, 2012
    #17
    Yea, this is an issue with the advanced sleep technique Apple uses. If you disable it (was linked earlier in this thread) it'll revert to normal sleep (where it doesn't force the contents of your ram onto the HDD -- that is what causes the delay, retrieving the data from your HDD) and be much much faster.
     

Share This Page