rMBP + Windows 8, Weird Graphics Performance?

Discussion in 'Windows, Linux & Others on the Mac' started by makaseo, Oct 29, 2012.

  1. makaseo, Oct 29, 2012
    Last edited: Oct 29, 2012

    makaseo macrumors newbie

    Joined:
    Oct 29, 2012
    #1
    Hi guys, wanted to see if anyone had the same problem as I do and help me out.

    Recently installed upgraded my Boot Camp installation to Windows 8. It's pretty cool! Except when gaming (I have the 15" rMBP, 2.3/8/256, but I think the only important spec is the GT 650m).

    Long story short, my gaming performance with Windows 8 is less than half of what it was with Windows 7. I used to be able to max out Borderlands 1 at 1920x1200 and get 40+ fps solid, but now I'm struggling to get 30fps at 720p with lowest settings. Other games like DX:HR and Just Cause 2 are similarly poor. It's almost like Windows decided to run games with the integrated HD4000, even though GPU-Z says otherwise.

    My drivers then and now have been 306.97, which is the latest set as far as I understand. I'm considering going back to the previous WHQL drivers but I get the feeling that it won't let me install it on Windows 8, since the OS wasn't supported. Another part of me wants to revert back to Windows 7 until "it's fixed," but I don't even know what the problem is so I won't be able to tell when it's okay to upgrade back up to 8.

    Let me know if you know anything. Thanks so much for any replies, I'd really appreciate some help!

    EDIT: Found a fix online! Had to reset the PRAM + something called SMC. Apparently it's a Mac thing. Everything's peachy now.
     
  2. inket macrumors regular

    inket

    Joined:
    Dec 23, 2009
    #2
    Install CPU-Z and check the processor's Core Speed when you feel games are running slow. If it's 1200Mhz, you're having a bad case of throttling.

    Try and see if an SMC reset fixes it.
     

Share This Page