rMBP with Graphical Glitches

Discussion in 'MacBook Pro' started by JoshuaA, Aug 28, 2012.

  1. JoshuaA, Aug 28, 2012
    Last edited: Aug 28, 2012

    JoshuaA macrumors member

    Joined:
    Apr 1, 2010
    #1
    My baseline rMBP arrived today, and first things first, I ran the IR test. Sure enough, LG panel has Image Retention that lasts 5-10 min. Can I deal with it? Possibly, I'll probably have a decision within the next 13 days.

    However, the real problem began when I loaded up a copy of WoW from my USB3 drive, cranked the graphics settings to Ultra quality. This is what I was greeted with:
    https://dl.dropbox.com/u/6743974/Screenshots/IMG_0962.MOV
    (apologies for the horrible quality video, but you get the idea)

    1. I toned down the settings to High, and it stopped.
    2. I put it back to Ultra to try taking an in-game video of it, and it still wouldn't do it.
    3. Restarting the game makes it happen for a while, until a trigger condition of sorts makes it stop (usually moving away from crowds, or starting to record video).
    4. Playing with Highest settings in Diablo 3 doesn't do anything.
    5. I ran the built-in Diagnostics on Extended mode with 0 errors.
    6. Software updated to latest, and hardly anything else installed yet.

    Anyone have an opinion on whether this is a Hardware (bad VRAM, maybe some bad GPU cores?) or a Software (Blizzard introduced yet another bug for the 5.x patch day) issue?

    Given these two strikes (possibly bad GPU/VRAM, and a LG panel with fairly visible IR issues), should I consider taking a trip to the Apple store for an exchange before it's too late?

    Thanks.
     
  2. JoshuaA, Aug 28, 2012
    Last edited: Aug 29, 2012

    JoshuaA thread starter macrumors member

    Joined:
    Apr 1, 2010
    #2
    Just as a follow-up, I was able to install Windows 7 along with Skyrim without any issues. It runs without any glitches on 12x AA + Ultra, although a bit slow. Disabling AA and turning a couple things down to High makes it playable, but the whole point of the experiment was to see if the GPU was suffering from a hardware issue.

    My observation so far is that it seems to be very localized to WoW on OSX on Ultra. I wouldn't be surprised if it was just a data corruption error from the patch update, so I'll try a full reinstall of WoW, but any ideas are still welcome.

    Edit: Full redownload later, no improvements found. Rather, it seems that it will glitch even on "High" mode. It just happens when logging in and opening my character sheet, especially near busy towns. It eventually stops doing it, and doesn't do it again afterwards, at least from my observations so far. It does sound like it could be a driver issue given how it goes away, but who knows.

    Edit 2: I installed StarCraft 2 on OSX, put it on Ultra settings, and played a simple match. No abnormalities. It really must be just WoW on OSX. Which still doesn't give me a clear answer, since no one else with a rMBP + WoW seems to have this issue.
     

Share This Page