rmpb takes 45 seconds to wake up after updates.

Discussion in 'MacBook Pro' started by iprime, Apr 1, 2013.

  1. iprime macrumors member

    Joined:
    Oct 6, 2011
    #1
    Hey guys, I finally got 2.7/16/512 rmbp last weekend. I did notice some scrolling lag on theverge.com compared to cMPB in store. I was told that the problem is with browsers not using multithread and what not.. At home, I noticed lag in mission control that went away after switching to Nvidia graphics with gfxcardstatus.

    I then installed the three updates including 10.8.3. The gfxcardstatus doesn't work anymore. After opening the lid, the macbook stays blank for 45 seconds and isn't responsive at all. After 45 seconds, I can login. I was very excited to have a powerful all in one machine after spending $2500 and wanted to keep for long time :/ Should I return it and wait for next gen ?
     
  2. B... macrumors 68000

    B...

    Joined:
    Mar 7, 2013
    #2
    SMC Reset: (sorry, again)

    Power
    The computer doesn't respond to the power button when pressed.
    A portable Mac doesn't appear to respond properly when you close or open the lid.
    The computer sleeps or shuts down unexpectedly.
    The battery does not appear to be charging properly.
    The MagSafe power adaptor LED doesn't appear to indicate the correct activity.

    As you can see, you meet the #2 criteria. Do these steps:

    1.Shut down the computer.
    2.Plug in the MagSafe power adapter to a power source, connecting it to the Mac if its not already connected.
    3.On the built-in keyboard, press the (left side) Shift-Control-Option keys and the power button at the same time.
    4.Release all the keys and the power button at the same time.
    5.Press the power button to turn on the computer.
    Note: The LED on the MagSafe power adapter may change states or temporarily turn off when you reset the SMC.
     
  3. mykem macrumors regular

    Joined:
    May 20, 2008
    #3
    The gfxCardStatus should work even after the 10.8.3 update.

    Another method to reduce scrolling lag on on sites like The Verge is to install Nightly Webkit: http://nightly.webkit.org/

    I find the webkit scrolls smoother on just the HD400 than Safari using the GT650M.

    As to the slow wake up time, you might want to read this and do the required changes: http://osxdaily.com/2013/01/21/mac-slow-wake-from-sleep-fix/
     
  4. iprime thread starter macrumors member

    Joined:
    Oct 6, 2011
    #4
    SMC reset fixed my waking up problem. When I set the card to dynamic switching or integrated only, sometimes (but not always), there is lag in mission control. The lag disappears when I switch to dedicated nvidia graphics. Is this hardware problem with intel hd 4000 ?
     
  5. mykem, Apr 1, 2013
    Last edited: Apr 1, 2013

    mykem macrumors regular

    Joined:
    May 20, 2008
    #5
    The point behind the integrated GPU is power efficiency and ultimately longer battery usage. Personally, I'd give up some UI smoothness for that. If you need the smoothness, keep it plugged in or force the use of the discrete GPU with ensuing reduction in battery usage. I think it's a good compromise.

    I'd also wait for the upcoming 10.8.4 update which will probably include the update to the HD4000 driver- supposedly increases the performance by 10% while reducing power consumption:
    http://ultrabooknews.com/2013/03/29/latest-intel-hd-4000-driver/
     

Share This Page