Robotic sounding mic audio for USB headsets with iMac

Discussion in 'iMac' started by abluehaze, Feb 16, 2014.

  1. abluehaze macrumors regular

    Joined:
    Aug 25, 2008
    #1
    A friend and I use VOIP while playing MMO's etc using either Message, Skype or Google Hangouts. He uses a USB headset and I don't. He recently replaced an older iMac with a new one as well as getting a new headset but he's still having the issues of his voice transmission sounding robotic at times.

    From what I've read this is a common issue with USB headsets on the iMac. Does anyone have any experience with this?

    I've read that some USB headsets work better than others on the iMac. He just recently got the Razer Kraken 7.1 and is having tons of problems with it. I read a comment from one person on a thread that they have a Steel Series V2 Frost Edition and it works fine.

    Anyone have any suggestions on gaming USB headsets or experience with the Razer Kraken 7.1?
     
  2. JustMartin macrumors 6502a

    Joined:
    Feb 28, 2012
    Location:
    UK
    #2
    There is a known problem with the latest Fusion Drive Macs and audio on USB, but it's more like pops and crackles than robotic.

    In my experience, voices starting to sound mechanical over VOIP (or similar) is connected to the bandwidth of the comms line or the load on the processor (both cause A->D converter to use a coarser sampling rate).
     
  3. mkatsey26 macrumors newbie

    Joined:
    Dec 29, 2014
    #3
    I'm still having this issue, but don't have a Fusion drive. 2013, Macbook Pro, Retina, 256gb SSD. Apple support can't seem to figure it out either.
     

Share This Page