Rogers/Fido launch Wi-Fi Calling

Discussion in 'iPhone' started by asharahmed, Sep 17, 2015.

?

Will you use Wi-Fi Calling?

  1. Yes

    87.5%
  2. No

    12.5%
  1. asharahmed macrumors regular

    asharahmed

    Joined:
    Sep 1, 2014
    #1
    Rogers and Fido have launched Wi-Fi Calling with iOS 9. It comes with the Carrier update version 21.1. Right now I can see the feature in Settings > Phone > Wi-Fi Calling but can't enable it. Also you need to remove Rogers One Number for it to work, among other things listed below:

    • Data blocking

    • Ringback tunes

    • Advanced Call Manager

    • Teletypewriter

    • Rogers One NumberTM
    Any luck with anyone else getting this feature to work?
     
  2. asharahmed thread starter macrumors regular

    asharahmed

    Joined:
    Sep 1, 2014
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
  4. john991 macrumors 6502a

    Joined:
    Sep 30, 2014
    Location:
    Ontario
    #4
    I'd like to but I get an error stating I need to call my carrier. Aka Fido and after 45 minutes on the phone the support rep,said the wifi system was down!
     
  5. stevemiller macrumors 65816

    Joined:
    Oct 27, 2008
    #5
    went though all the steps, it said it was successfully enabled for my account, but the toggle remained off. when i tried to enable it again, it just looped through the sign up steps again.
     
  6. john991 macrumors 6502a

    Joined:
    Sep 30, 2014
    Location:
    Ontario
    #6
    Are you on fido or Rogers?
     
  7. stevemiller macrumors 65816

    Joined:
    Oct 27, 2008
    #7
    fido.
     
  8. kazibole macrumors member

    Joined:
    Jan 18, 2015
    #8
    I'm on Rogers. I tried to enable it last night and it did not work (please contact carrier). I tried again this morning and it worked fine and I was given the e911 page to fill out.
     
  9. john991 macrumors 6502a

    Joined:
    Sep 30, 2014
    Location:
    Ontario
    #9
    Lucky you! I still get the error this morning on Fido!
     
  10. asharahmed thread starter macrumors regular

    asharahmed

    Joined:
    Sep 1, 2014
    #10
    According to Rogers the issue is with adding Wi-Fi Calling to an account that has a non Rogers IMEI, as in if the phone you are attempting to use was not purchased by Rogers. They are working to fix the issue.
     
  11. ncorriveau macrumors newbie

    Joined:
    Jun 17, 2009
    Location:
    Ottawa, ON
    #11
    I have an unlocked Apple store purchased iPhone 6+ and was able to enable it after I got Rogers One Number removed from my account. It took two chat sessions with Rogers support to get it cleared up.
     
  12. john991 macrumors 6502a

    Joined:
    Sep 30, 2014
    Location:
    Ontario
    #12
    Still no go for me on Fido. Still getting contact your carrier error message.

    I have a case number with Fido so hopefully they'll fix my issue sooner than later.
     
  13. Mase macrumors newbie

    Joined:
    Apr 8, 2007
    #13
    I have been trying to get it for a week and finally it worked yesterday.
     

Share This Page