Rome Total War

Discussion in 'Mac and PC Games' started by 11dnewell, Jun 3, 2010.

  1. 11dnewell macrumors newbie

    Joined:
    Jun 3, 2010
    #1
    Just bought Rome Total War Gold Edition for macintosh and have run into some trouble. I just installed it on my macbook (10.5.8) and it seemed to have installed fine. However, when I go to start campaign it crashes the entire macintosh right after they show the introduction video of the family that you chose. Has this happened to anyone else and does anyone know of any ways to fix this? Thanks in advance!
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    What specific and exact Mac model do you have?
     
  3. ZazenZach macrumors member

    Joined:
    Dec 23, 2009
    #3
    it's probably because your video card is not supported. when you buy video games you need to look on the box to make sure you meet the system requirements.
     
  4. 11dnewell thread starter macrumors newbie

    Joined:
    Jun 3, 2010
    #4
    I can now play the game for about 15 minutes before it shuts down. It runs fine and randomly shuts down. MY comp has the 2GHz intel core 2 duo for a processor. It says that this processor is supported on the back of the game. I believe this NVIDIA GeForce 9400M is the video card but I could be mistaken. I don't know a whole lot about comps but I just want to play this game.
     
  5. IanAtFeral macrumors member

    IanAtFeral

    Joined:
    Sep 15, 2009
    #5
    Hey 11dnewell,

    The best thing to do, if you haven't already, would be to email our support ninjas at support@feralinteractive.com . They should be able to help you out – make sure you put 'Rome Total War' in the email subject.

    – Ian :)
     
  6. 11dnewell thread starter macrumors newbie

    Joined:
    Jun 3, 2010
    #6
    Thanks Ian! Just shot them an email with the explanation and the thing that they tell you to attach in the email. Do you know if they will just email me back when they can fix it or (hopefully not) tell me that I won't be able to play it?
     
  7. 11dnewell thread starter macrumors newbie

    Joined:
    Jun 3, 2010
    #7
    Alright so I just received an email from the support team and they said that they can't find any apparent issue with the software or installation. So now I am in desperation mode trying to figure out what is wrong. I don't believe the cd is scratched since I got it yesterday and all I have done is install it. So if anyone else has any suggestions I would be most appreciative.
     
  8. 11dnewell thread starter macrumors newbie

    Joined:
    Jun 3, 2010
    #8
    Ok so i tried ejecting the disc once it started up and...it worked for literally six hours with no crash. Now I went to try this again tonight and....it shuts down after 25 minutes...lol I must be cursed or something.
     
  9. deadwulfe macrumors 6502a

    deadwulfe

    Joined:
    Feb 18, 2010
    #9
    I don't really see how ejecting the disc has any actual effect on the game crashing. If the disc is in good enough condition to install the game, it's in good enough condition to help it pass the disc check.

    You say you're not good at computers and you're not confident what graphics card you have so I was thinking that you should try a disk utility repair permissions...

    Press Command + Spacebar to open up a spotlight search. Then type in the phrase disk utility and press enter. This opens up the Disk Utility app. The app is split into two panes, left and right.

    On the left hand side, click on your Mac's hard drive partition, probably named Macintosh HD. Then in the right hand side window, below the big empty white box, click on the Repair Disk Permissions button. This will take a few minutes so enjoy your cup of coffee or tea.

    When it's done, try running Rome TW again, but don't bother trying to eject the disk. Let us know how it goes.
     

Share This Page