Root Password Gone Starts Up with UNIX command prompt

Discussion in 'macOS' started by matt18012, Sep 11, 2005.

  1. matt18012 macrumors member

    Apr 24, 2003
    Big problem here:

    I accidently deleted a folder called "private" while i was messing with some network stuff with "show invisible folders" enabled in the finder. After I deleted the folder, my password no longer worked to authenticate any programs. I restarted my machine and now it only boots into a command line prompt (black screen, white text) and says something like, "no mastr passwrd" I'm guessing I deleted the user root password and OSX can't get past the prompt. Is there a way to reset my password from this prompt, or am I doomed to a complete reinstall? I tried booting from the install cd and resetting the password from there, but it doesn't recognize my disk as having osx installed on it. Oddly, it does allow me to select my HD as a startup disk, and shows it has OSX 10.3.9 installed. Here's my specs:

    iBook 700mhz G3
    640 mb ram
    OSX 10.3.9

    Thanks guys!
  2. wrc fan macrumors 65816

    wrc fan

    Jan 19, 2003
    In a world where LPs are made like pancakes
    If you have a backup, you could put that folder back from a backup, but if you don't the only way will be from a reinstall. Never never delete any hidden directories in the root of the hard drive (/usr, /etc, /private, /bin, /dev, etc...)
  3. risc macrumors 68030


    Jul 23, 2004
    Melbourne, Australia
    /private is where OS X keeps most of it's system config files, you f$cked up... you'll probably need to reinstall - sorry.

Share This Page