Rosetta Stone V3 and Snow Leopard

Discussion in 'macOS' started by StevenShort, Aug 29, 2009.

  1. StevenShort macrumors newbie

    Joined:
    Jul 26, 2009
    #1
    Alright, does anyone who has upgraded to Snow Leopard use Rosetta Stone? If so, does it work?

    Thanks!
     
  2. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #2

    I used it to play Bejeweled 2, and it worked fine.
     
  3. StevenShort thread starter macrumors newbie

    Joined:
    Jul 26, 2009
    #3
    I was meaning Rosetta Stone language learning software. Specifically German.
     
  4. jive turkey macrumors 6502

    Joined:
    Mar 15, 2008
    #4
    Duh! Sorry man, I totally missed the Stone in your original post. Reading too fast for my own good.
     
  5. daflake macrumors 6502a

    Joined:
    Apr 8, 2008
    #5

    Yep, no problems here.
     
  6. StevenShort thread starter macrumors newbie

    Joined:
    Jul 26, 2009
    #6
    It's all good! I understand!

    Thanks guys, just making sure before I upgrade... Learning German is more important than Snow Leopard! :D
     
  7. Dragonforce macrumors 6502a

    Dragonforce

    Joined:
    Apr 9, 2008
    Location:
    London (Ealing) UK
    #7
    Funny :eek: because I'm native German :p (if you need help with anything, feel free to ask or even Skype me)
    I'm using RS3 to learn Japanese, and yes, it works flawlessly.
    You would expect nothing less from a program which is that expensive.
     
  8. StevenShort thread starter macrumors newbie

    Joined:
    Jul 26, 2009
    #8
    That is awesome! Thank you so much! Where in Germany are you from? Maybe I could get your email address? I'm trying to find books and movies in German to help with my vocabulary and grammar, hopefully seeing it more will improve that. Do you now live in the states?
     
  9. mlgallen macrumors newbie

    Joined:
    Sep 4, 2009
    #9
    Rosetta Stone not working with Snow Leopard

    From the moment I installed Snow Leopard beta, my Rosetta Stone (French and Gaeilge) stopped working. Thought the Snow Leopard final release might 'fix' it, but no. Neither version is working - and that's an expensive problem.
     
  10. jacobwright macrumors newbie

    Joined:
    Sep 7, 2009
    #10
    Usable with a few strange behaviors

    After I upgraded to Snow Leopard, Rosetta Stone V3 Spanish (Latin America) started lagging and skipping a bit before verbal exercises. Did anyone else notice anything like this?

    Certainly doesn't hamper overall usability, but it is annoying.
     
  11. clayjars macrumors newbie

    Joined:
    Oct 21, 2009
    #11
    In general Rosetta Stone (v3 German) has been working for me after the Snow Leopard install.

    I have noticed some slight shuttering during the motion of in certain situations (few).

    I have also noticed that sometimes the first slide in a multiple slide selection screen gets auto selected correct and the text above the picture highlighted throughout the completion of the exercise. For example, when learning the names of the days of the week one of the days gets picked right away.

    The biggest issue I have is that with the writing exercises the Shift key doesn't work. Somewhat of a problem with German. So I have to click the shift key on the keyboard displayed on the screen and then type the letter.

    I have noticed that if you haven't used the software for a couple months and they ask you to do an older lesson its often gotten stuck asking me to do the same lesson again (like I just logged in to the software, not like when you do poorly on the lesson). I think this was actually a problem before Snow Leopard.

    I might try re-installing and see if that does the trick.
     
  12. lorenzorlarry macrumors newbie

    Joined:
    Nov 26, 2010
    #12
    rosetta Stone 4e

    I have just purchased Rosetta Stone 4e Spanish Latin America. The application will not load on my mac with snow leopard. I have spent more than 3 hours with Rosetta Stone tech support, even going so far as to let the tech take control of my computer. So far it doesn't work. Anyone have any ideas or experience with this? It did load and work properly on my wife's computer using leopard.
     
  13. mgdf17, Dec 27, 2010
    Last edited: Dec 27, 2010

    mgdf17 macrumors newbie

    Joined:
    Dec 27, 2010
    #13
    Same Problems with German

    My wife recently bought me Rosetta Stone German level 1, and I am trying to install it on a MacBook running Snow Leopard. The 1st disk, Application, installs, but when you try to open the program it opens a blank screen. The instructions claim that there will be a prompt to install a language, but that never happens. Before I call tech support and potentially get similar results to those of lorenzorlarry, I thought I would post here to see if anyone has any ideas. I tried repairing the disk and disk permissions because I read that this might work on another forum, but no luck. I still have the same thing happen.

    Thanks!

    - mg

    P.S. I am trying to install v4 TOTALe.
     
  14. absurdio macrumors 6502

    Joined:
    Aug 25, 2003
    Location:
    RI, Chi, and/or NY.
    #14
    I've got that problem too. Extremely annoying. For whatever reason, Rosetta Stone just doesn't seem to register my keyboard's Caps Lock or Shift keys. Likewise, I'm stuck clicking on and off the virtual shift key. Yuck.
     
  15. wolfpaws macrumors newbie

    Joined:
    May 29, 2011
    #15
    It mostly works

    I'm using the French Version 3 program and just upgraded to a G5.

    The bug in Version 3, where the shift key doesn't work in the writing exercises is still an intermittent problem. (I had the problem in 10.4.11, and though it shows up less, it is still a problem in 10.6.7.)

    Rosetta Stone support told me to upgrade to a G5 and the problem would go away. Alas, they lied.

    Today, when pressed hard-- support shared with me a way to "kick" the program and make it work again. If you change the keyboard settings from one keyboard layout to another in the Rosetta Stone preferences, then restart the program, the shift key works again. Then you can change it back to the keyboard layout that you had before.

    Support for Rosetta Stone seems to be kind of sketchy. (They always tell me as a first answer, "That's just a feature not supported on the Mac." That's never true, and if I persist, they'll find other things to say-- but ultimately-- they know the program has bugs in the Mac version and they choose not to fix it in the updates. That's sketchy in my book.

    So far, everything else works the same as it did in Tiger.

    Hope that helps.
     
  16. alexiarudolf macrumors newbie

    alexiarudolf

    Joined:
    Jun 6, 2011
    Location:
    California
    #16
    Re: Rosetta Stone V3 and Snow Leopard

    yes, i did and it works pretty smooth, without any trouble. BTW this application is also now available for iPad as an iPad App and is available in the App store too.

    Alexia
     
  17. ManfromNAm macrumors newbie

    Joined:
    Jul 19, 2011
    Location:
    Ha Noi, Viet Nam
    #17
    Bad audio experience

    I tried to install the Rosetta Stone American English V3 for my wife (who does not speak English well) on our new imac 2.93 Quadcore i7 with Snow Leorpard OS; however, I was not able to make the audio work. Our headphone and mic worked well with other applications, including Skype, but somehow does not work well with the RS program, especially the mic. I have tried different mic/headphone sets and ran into the same problem. What kind of headphone/mic sets are people using that seem to work?
     
  18. Conner36 macrumors member

    Conner36

    Joined:
    Feb 4, 2006
    #18
    I had a problem with the mic too at first. I had to go into my system preferences/sound and change the input. After doing that I stopped getting the choppy mic. Make sure that mic rosetta is using is not the same as the one in the system preferences and things should be good.

    Hope that helps :)
     
  19. adoapplemac macrumors newbie

    Joined:
    Aug 15, 2011
    #19
    This is supposed to happen. Rosetta Stone designed some pages to do that to help you with the screen.

    I also have v4 now, so many problems have been fixed.
     
  20. badman89, Feb 22, 2012
    Last edited: Feb 22, 2012

    badman89 macrumors regular

    Joined:
    Dec 24, 2011
    #20
    Hi, I'm facing the same exact problem right now. In Snow Leopard, I can't use the Shift or Caps keys in Rosetta Stone.

    But additionally, I'm also facing another problem: If I go to "Set Preferences" I'm unable to change the keyboard layout in course settings. So I can't even try your fix.

    Any ideas?
     

Share This Page