Rosetta Stone

Discussion in 'Mac Apps and Mac App Store' started by jackwigs, Aug 15, 2008.

  1. jackwigs macrumors newbie

    Joined:
    Aug 13, 2008
    #1
    Does anyone know if the new Rosetta Stone language course works with 10.3.9?
    On the box it says only 10.4 or above but on their web page f.a.q it says it works with 10.3.9, I emailed then and they gave a rather wet answer of

    "No, I can't guarantee that your 10.3.9 will work. Our current system requirements support 10.4 and above. You can purchase the software and install to your computer, but if you run into issues, we may or may not be able to assist you."
     
  2. wordmunger macrumors 603

    wordmunger

    Joined:
    Sep 3, 2003
    Location:
    North Carolina
    #2
    Sounds like they answered your question for you. You might try looking for an older used version of the software that would work on an older computer (via ebay, for example).
     
  3. jackwigs thread starter macrumors newbie

    Joined:
    Aug 13, 2008
    #3
    Rosetta Stone

    thanks for the reply, I have tried to see if there was an older version but they don't seem to sell all 3 courses. I was hoping someone out there may have brought it and tried it on !0.3.9 because I'm nervous at spending £260 on a course that may not work!
     

Share This Page