Router problem (DNS)

Discussion in 'Mac Basics and Help' started by recklesser, Oct 31, 2009.

  1. recklesser macrumors newbie

    Joined:
    Oct 31, 2009
    #1
    Hi everyone,
    I have a very very anoying problem but i have a very detailed description so i think this will help.
    When i make connection with my router i do not have internet, but I go to my network options and i click TCP/IP and then "renew DHCP-lease". The "Router" number change from 192.168.2.1 to 192.168.3.1, and then my internet works.
    But if i have to restart my mac for some reason, it jumps right back to 192.168.2.1, and i have to click "renew DHCP-lease" again.
    I have this on my both Macs (MacBook unibody allu, and MacBook white and also on my iPhone).
    I hope somone can fix this problem.
    Thanks on forehand.
     
  2. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #2
    Are your settings set to pull DHCP or is there some information already there? You want everything blank and set to pull DHCP.
     
  3. recklesser thread starter macrumors newbie

    Joined:
    Oct 31, 2009
  4. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #4
    Same place you do the renew. System Preferences -> Network -> highlight your network adapter you are using (Airport for wireless, Ethernet for wired) -> Advanced -> TCP/IP.

    Also, do you see the same issue when wired vs wireless?
     
  5. recklesser thread starter macrumors newbie

    Joined:
    Oct 31, 2009
    #5
    Everything is blank.
    I have the same problem with ethernet, so it gives me 192.168.2.1. The only difference is that if i click renew it doesn't change to 3.1 :s
     
  6. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #6
    I'd reset your router to the defaults and set it up again. Something sounds fishy with it.
     
  7. finnschi macrumors 6502

    Joined:
    Dec 30, 2008
    Location:
    Hamburg, Germany
    #7
    do you maybe have 2 Routers in your home network(one as a wifi repeater or something?), you are apparently getting a gateway address from a FALSE DHCP server!

    you could TUNR DHCP OFF (give yourself a manual IP adress) but this way you would have to change back to DHCP when you are using your macbook/iPhone on another wifi Network.

    OR

    go to your router setting (type router ip adress 192.168.3.1 in browser) and change your routers Ip to 2.1)

    OR

    it might just be the DNS... add 208.67.222.222, 208.67.220.220 to your DNS (its Open DNS , a very very good DNS)


    I am a network specialist, if you need more help feel free to contact me directly /Skype or something :D
     
  8. recklesser thread starter macrumors newbie

    Joined:
    Oct 31, 2009
    #8
    I found something new here.
    We have a windows laptop, and i this one is on then my network is crap like i told. BUT: When the computer is off, then my internet is perfect...
    I changed my router ip to 2.1 and i let you know if this solves the problem!
    Thank you very much for the help.
     

Share This Page