Ruby 2.0 to Ruby 1.8 Issue

Discussion in 'macOS Sierra (10.12)' started by JB26, May 7, 2017.

  1. JB26 macrumors newbie

    Joined:
    Sep 24, 2012
    Location:
    Yorkshire
    #1
    Hey, I'm new(ish) to Mac and recently purchases a MBA. I work as a teacher and use a piece of software called Smart Notebook 11.4. After setting up my Mac and being more than happy with it I tried to install the app. It wouldn't open and after a bit of research I found others with the same problem. It seemed that in 10.11 the app needed Ruby 1.8 framework to run. I entered boot mode and disabled SIT temporarily to install Ruby 1.8 that I Tok from an old Mac running Mavericks using terminal (I found the workaround online). However, after doing it the app still doesn't work and it seems the workaround doesn't work with Sierra.

    So my question is, how do I revert back to Ruby 2.0? My partner has a MBA with 2.0 could I just copy it over from that?

    Thanks in advance
     
  2. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012

Share This Page