ruby + mysql gem

Discussion in 'Web Design and Development' started by werther, Jul 5, 2007.

  1. werther macrumors regular

    Joined:
    May 15, 2006
    #1
    I am trying to get the mysql gem for ruby to work on tiger. Does anybody have a solution to this? I checked google but get a ton of different solutions, several of which I have tried ( need I say -to no avail).

    -Thanks for any help in advance.
     
  2. werther thread starter macrumors regular

    Joined:
    May 15, 2006
    #2
    ok I solved the problem. Perhaps some here already know/knew this but I will detail what I had to do.

    It seems the ruby build that comes with tiger sucks balls and though there are 'fixes' for configuration files, etc none of them seemed to work for me (and not for many others after looking in other forums)

    So first I had to install XCode from my Mac installation CD

    this was easy but I should have read further in the forums as XCode takes up a ton of space (about 9 gigs). You can do a custom install but need to make sure that these packages are checked:
    * Developer Tools Software
    * gcc 4.0
    * gcc 3.3
    * Mac OS X SDK
    * BSD SDK
    * X11 SDK
    * Mac OS X 10.4 (Universal) SDK
    -again I installed XCode in its entirety, so me stating that the above listed packages are all you need is simply relying on forum posts on other sites.

    then Install darwinports (now known as MacPorts)

    after MacPorts installs hit up terminal and key: sudo port selfupdate

    then to install the gem (the mysql gem is the one I had problems with) type into terminal:
    sudo gem install mysql -- --with-mysql-dir=/usr/local/mysql

    -check first to make sure the above directory is the same as yours.
     

Share This Page