Rules In Mail

Discussion in 'Mac Apps and Mac App Store' started by Macs~R~Us, Jun 7, 2008.

  1. Macs~R~Us macrumors newbie

    Joined:
    May 28, 2008
    #1
    When using Mail I am trying to make a received Message title text coloured.

    I have been into the 'Rules' section & set each of my e-mail accounts to a separate colour. But they always come through in an Olive colour.

    Maybe I am setting the Rules up wrong? I have them set as follows ~
    If All...Sender Not In My Address Book...Set Colour Of Text...'Red'

    I have set that rule for all account but with a different colour.

    What setting do I need to use in the rules to get each message a different colour.

    Cheers
     
  2. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #2
    You'll need a rule - if to [account name] for each account and the each has an 'if not in Address Book' colour line.
     
  3. Macs~R~Us thread starter macrumors newbie

    Joined:
    May 28, 2008
    #3
    Hi
    I got an 'If Any' & an 'If All' but no 'If To'

    Tried what you suggested in a way but still all text is in the same colour.

    Thnx
     
  4. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #4
    My mistake.
    "If any"
    'From' 'Contains' [email address]

    Perform action
    'Set color' 'of text' [color]
     
  5. Macs~R~Us thread starter macrumors newbie

    Joined:
    May 28, 2008
    #5

    Attached Files:

  6. chocodup macrumors member

    chocodup

    Joined:
    May 17, 2008
    #6
    I had the same kind of problem some times ago.

    The problem was that another rule with a higher priority (= higher in the rule list) was applied for the same mail.

    For a given mail, Mail only applies the first rule that matches the conditions.
    I resolved my problem by defining more than 1 action in the former rule.

    Perhaps, you are facing the same problem.
    Hope this helps...
     
  7. Macs~R~Us thread starter macrumors newbie

    Joined:
    May 28, 2008
    #7
    Ok...Now I'm Lost :confused:...maybe you could post a picture to illustrate?

    Thanks
     
  8. Cromulent macrumors 603

    Cromulent

    Joined:
    Oct 2, 2006
    Location:
    The Land of Hope and Glory
    #8
    Just click the + button on the appropriate line.
     
  9. Macs~R~Us thread starter macrumors newbie

    Joined:
    May 28, 2008
    #9
    Cheers for the help.

    Still got no clue.

    Thnx
     
  10. eluk macrumors 6502a

    eluk

    Joined:
    Dec 14, 2006
    Location:
    East London, UK
    #10
    Have you applied the rule? Opt+Command+L.

    Otherwise as Chocodup suggest check what other rules run.

    I use this rule using coloured background rather than text and it works fine.
     
  11. Macs~R~Us thread starter macrumors newbie

    Joined:
    May 28, 2008
    #11
    Yes I did apply.

    I tried the background colour & found it a little 'messy'. Still cannot get the txt to be coloured.

    Anyone know of a tutorial some where on the net?

    Thanks again
     
  12. chocodup macrumors member

    chocodup

    Joined:
    May 17, 2008
    #12
    I hope that it will be clearer with the capture example.

    I made the capture of the Mail/Preferences window (tab Rules).

    In this capture, there are many rules.
    The "Mac Forum" one has a higher priority than the "Saturn" one because it is higher in the list (see capture).

    Imagine :

    • the condition associated to "Mac Forum" rule is "From contains @macrumors.com" and the associated action is "Move message to mailbox Forum".

    • the condition associated to "Saturn" rule is "From contains webmaster@" and the associated action is "Set the message color to blue".

    • you receive a mail from "webmaster@macrumors.com"

    => Your mail matches the 2 rules, but only the highest priority one (Mac Forum) will apply.
    Your mail will be moved to mailbox "Forum" but will not be set in blue.

    This can explain why your new rules does not apply (check the rules that have a higher priority). You can move your rules up and down if you want (drag 'n drop a rule).

    If you want your mails from "webmaster@macrumors.com" to be moved to mailbox "Forum" AND to be set in blue, you can define the 2 actions (or more) in the same rule by clicking the + button (see red squared + button) when editing the rule
     

    Attached Files:

  13. andiwm2003 macrumors 601

    andiwm2003

    Joined:
    Mar 29, 2004
    Location:
    Boston, MA
    #13
    mark all mails by shift/clicking them and goto message/apply rules.

    then it should work for all old mails as well, not only the ones that came in after you set the rule.

    essentially do Command+A and then Opt+Command+L
     
  14. Macs~R~Us thread starter macrumors newbie

    Joined:
    May 28, 2008
    #14
    Thanks for you patience guys.

    I'm a retard...I just don't get it.

    Still got all text black.

    Cheers
     
  15. jplan2008 macrumors regular

    Joined:
    Feb 15, 2008
    #15
    add account to rule

    Hi, 2 things:

    1) When you add a rule, it is by mailbox (where you currently are), not by account. So -- if all your messages from different accounts go through your inbox, you'd be adding different rules saying different things.

    What you want to do -- while in inbox: if ALL conditions are met:

    account XXX

    click +

    recipient is not in address book,

    then

    color of text red...

    then copy the rule and change the account and the color, etc...

    (and remember to delete your other rules that didn't work)

    Apply to all messages each time (but will only apply to ones still in the inbox). Like others have said, make sure this rule is BEFORE any moving or copying rules.

    2) You initially said all messages are "olive" color then you said black. The junk mail filtering rules supersede all rules. So mail will set color to a light brown (olive?) color based on certain conditions. In preferences, go to junk mail, check "perform custom actions," then click advanced to change the rules re. junk mail (think default is if not in address book, and sender doesn't use full name, etc. You can take away certain attributes, or just turn filtering off)

    Good luck.
     
  16. Macs~R~Us thread starter macrumors newbie

    Joined:
    May 28, 2008
    #16
    Ok..I think I got it working after reading jplan2008's instructions.

    Fingers crossed

    Thanks to all who posted..

     

Share This Page