rumbling ipod.. normal?

Discussion in 'iPod' started by Chemical, May 4, 2008.

  1. Chemical macrumors newbie

    Joined:
    May 4, 2008
    #1
    First post, so hello everyone :)

    I've searched around on this forum for my problem. I've seen a few similar posts but nothing quite the same.

    I've had my iPod Classic since last November. It's worked fine throughout, except for needing the odd reset.
    Last night however I noticed it started making odd noises, I can now physically hear the hardrive spin (well I assume its the hardrive spinning) when i go to do certain things: shuffle songs, play/pause and whatnot.
    The sound is kind of like 2 pieces of rubber rubbing together. It does the same sequence of noises every single time:

    Hardrive spinning sound
    Then a kind of slicing/settling sound, similar to when you put a disk in a suction disk drive.

    I can also physically feel these actions going on in my hand, i can feel the vibration of the hardrive spinning and the clicking/settling.

    Also when I shake it, i can hear something tiny shaking around.

    My instinct would be that somethings snapped off, causing this noise when the hardrive moves, as i never heard ANYTHING before. But maybe its just normal? should I return it to the store?

    I have breakdown cover but am wondering if they'd really accept it as broken.


    Thanks alot for any help
     
  2. MacAodh macrumors regular

    Joined:
    Apr 3, 2006
    Location:
    Dublin, Eire
  3. Satori macrumors 6502a

    Satori

    Joined:
    Jun 22, 2006
    Location:
    London
    #3
    They certainly should not sound the way you describe... Take it back for repair.
     
  4. Auzburner macrumors 65816

    Auzburner

    Joined:
    Apr 11, 2008
    Location:
    Syracuse, NY - USA
    #4
    Most definitely take that to Apple. They should fix the problem unless obvious abuse is present, you should have no trouble. Before it gets worse you need to have it checked out...
     
  5. Chemical thread starter macrumors newbie

    Joined:
    May 4, 2008
    #5
    Thanks for the help guys.

    I bought it from PC World (UK) and got some breakdown cover thing with them, just took it back today, till then It looks like im using some old 512mb AAA Battery mp3 player :(
     

Share This Page