Run as Admin? Eh?

Discussion in 'macOS' started by sehnsucht77, Apr 8, 2012.

  1. sehnsucht77 macrumors 6502

    Joined:
    Dec 26, 2008
    #1
    i am trying to run a program to update via terminal and ran into a snag with the following message:

    "You don't have permission to change the installation in any way,
    specifically, the directory /usr/local/*****/*****/*****/ is not writable.
    Please run this program as administrator, or contact your local admin."

    Thing is, I am the admin and there is only one account on my laptop which DOES have admin rights. I was logged in as the Admin when I tried to run the script to update a program.

    How do I deal with this? Thx
     
  2. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
  3. Pheo macrumors regular

    Joined:
    Jun 13, 2011
    #3
    Yep, admin permissions are normally not granted unless specifically requesyed
     
  4. sehnsucht77, Apr 8, 2012
    Last edited: Apr 8, 2012

    sehnsucht77 thread starter macrumors 6502

    Joined:
    Dec 26, 2008
    #4
    Thanks y'all. I tried sudo and the command went through.
     

Share This Page