Runaway Kernel_task

tomgorman

macrumors newbie
Original poster
Oct 25, 2007
3
0
I've got a month-old MBP and starting yesterday the kernel_task has jumped to 105% of CPU usage and is completely bogging down my system (and killing my battery).

Here's what I've already tried to isolate the problem:

Restart
Correct permissions/fix file system (with Disk Utility and fsck)
Cleared space on the HD (in case the problem was with swapping)
Tested to see if the problem reproduced in a brand new user acct (it did)
Cleared system and user caches
Started in safeboot mode
Ran TechTool to look for hardware problems
Re-installed OS.

Here's what Console.log says soon after restart.

Mac OS X Version 10.4.10 (Build 8R4061a)
2007-10-25 09:23:24 -0500
2007-10-25 09:23:25.152 loginwindow[467] FSResolveAliasWithMountFlags returned err = -43
2007-10-25 09:23:25.274 HPEventHandler[496]: DebugAssert: Third Party Client: (NULL != m_lock && 0 == errno) Can't create semaphore lock[/Volumes/Development/HP/Mac-Sirani/mac-software/components/HPEventHandler/Sources/Core/HPTMNotificationManager.cpp:62]
2007-10-25 09:23:26.712 SystemUIServer[486]
MenuCracker
see http://sourceforge.net/projects/menucracker
MenuCracker is now loaded. Ready to accept new menus. Ignore the failure message that follow.
2007-10-25 09:23:26.715 SystemUIServer[486] failed to load Menu Extra: NSBundle </Library/PreferencePanes/MenuMeters.prefPane/Contents/Resources/MenuCracker.menu> (loaded)
2007-10-25 09:23:27.311 SystemUIServer[486] CFLog (21): dyld returns 2 when trying to load /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio
2007-10-25 09:23:27.316 SystemUIServer[486] CFLog (22): Cannot find function pointer NewPlugIn for factory C5A4CE5B-0BB8-11DOct 25 09:23:27 Lair-of-Tomcat-IV /usr/sbin/AppleFileServer: AFPServer::AbnormalATListenerShutDown - clear listener
8-9D75-0003939615B6 in CFBundle/CFPlugIn 0x3bcc70 </Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin> (bundle, not loaded)
2007-10-25 09:23:28.771 SystemUIServer[486] Normally MenuMeterMemExtra would not have been loaded as a Menu Extra.
2007-10-25 09:23:28.789 SystemUIServer[486] MenuMeterMem loaded.
2007-10-25 09:23:28.789 SystemUIServer[486] Normally MenuMeterCPUExtra would not have been loaded as a Menu Extra.
2007-10-25 09:23:28.968 SystemUIServer[486] MenuMeterCPU loaded.
Oct 25 09:23:29 Lair-of-Tomcat-IV mDNSResponder: getifaddrs ifa_netmask for vmnet1(5) Flags 8863 Family 2 192.168.120.1 has different family: 0
Oct 25 09:23:40 Lair-of-Tomcat-IV mDNSResponder: getifaddrs ifa_netmask for vmnet1(5) Flags 8863 Family 2 192.168.120.1 has different family: 0
Oct 25 09:23:43 Lair-of-Tomcat-IV mDNSResponder: getifaddrs ifa_netmask for vmnet1(5) Flags 8863 Family 2 192.168.120.1 has different family: 0
Oct 25 09:23:43 Lair-of-Tomcat-IV mDNSResponder: Repeated transitions for interface en1 (10.0.1.200); delaying packets by 5 seconds


Anyone have any thoughts?

My next step would be to wipe the drive and do a clean install, but my external HD is a mess right now and I have no place to put my data.

Thanks!
 

tomgorman

macrumors newbie
Original poster
Oct 25, 2007
3
0
Runaway Kernel_Task

did you recently get any new peripherals that you just hooked up?
Nope. I've got a Firewire external HD that's been giving me trouble lately but that's been a problem for weeks and this kernel problem only started yesterday.

--tom
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.