RunCore and MyDigitalDiscount support

Discussion in 'Buying Tips and Advice' started by iBookG4user, Dec 2, 2009.

  1. iBookG4user macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #1
    Well, I recently posted a thread about how I was having problems with the RunCore SSD that I had just bought. I got it to work after hours of troubleshooting it myself and then it died an abrupt death ten days later. Now, fast forward to the support, I contacted MyDigitalDiscount just over two weeks ago and included all the information. I have yet to receive any response and I sent a followup email a week after the first and received no response. So much for the support or return policy for them.

    Next I went to RunCore's website to try to get a replacement from them. I sent the first email to them just over a week ago and then again after 4 days. They too gave me no response whatsoever. The RunCore SSD is very fast, although it seems that support is almost nonexistent. I expect much more support for a drive that costs nearly five hundred dollars.

    I know that Scottsdale speaks very highly of the drive and I would too, if it worked. Although I'd take a few moments and think of what if the drive doesn't work and you get put in the same situation I am right now. Currently I wouldn't recommend the drive to anyone.

    EDIT:
    Runcore PM'd me and it was taken care of, at last.
     
  2. J&JPolangin macrumors 68030

    Joined:
    Jul 5, 2008
    Location:
    Thule GL @ the TOW
    #2
    ...yeah, they are the main company I found that makes a 1.8" ZIF SSD but I didn't get a great feeling when trying to purchase from them or any of their affiliates so I passed on it.

    I hope you get the problem worked out.
     
  3. GoCubsGo macrumors Nehalem

    GoCubsGo

    Joined:
    Feb 19, 2005
    #3
  4. iBookG4user thread starter macrumors 604

    iBookG4user

    Joined:
    Jun 27, 2006
    Location:
    Seattle, WA
    #4
    I sent him a PM about it 3 days ago, although it seems that he has not logged into the forums since then. So, I haven't received a reply from them either.

    Runcore just PM'd me and within an hour I got an email from MDD and got it taken care of. They're going to ship me a new one, so that's good news. I still think they need to work on their support some, although at least they're going to replace it. It looks as though Runcore on here is the best means of contacting them for support.
     

Share This Page