Runkeeper and certain apps won't open on Apple Watch

Discussion in 'Apple Watch Apps' started by 212rikanmofo, Jan 4, 2016.

  1. 212rikanmofo macrumors 65816

    Joined:
    Jan 31, 2003
    #1
    I can't get runkeeper to launch on my apple watch and certain other apps as well. I even tried to unpair and re-pair the watch and set it up as a new watch but the app still won't launch.

    Any ideas why? I am using the latest WatchOS 2.1. I tried to uninstall and reinstall the app and still nothing. Sigh. This has been an on-going issue for me even with the previous WatchOS.
     
  2. TypeMRT macrumors 6502

    Joined:
    Sep 7, 2007
    #2
    I'm having the same problem. I narrowed the cause to upgrading from an iPhone 6 to a new iPhone 6s (plus). Something weird happened when restoring to the new iPhone (both were using iOS 9) and the only solution is to setup the iPhone and watch as new. I tested this and it completely solved the problem of apps not launching.
    But, I restored from the bad iPhone backup because I didn't want to lose a bunch of iPhone data (high scores, messages, settings, etc). I really hope a watchOS update and/or iOS update fixes this. So far the minor updates haven't. I really miss Fantastical, Dark Sky, & RunKeeper on my watch.
    --- Post Merged, Jan 4, 2016, Original Post Date: Jan 4, 2016 ---
    This worked. I have no idea how deleting music is the solution but it's working so far.
    http://forums.macrumors.com/threads/native-apps-do-not-load.1919307/page-25#post-22430334
     
  3. 212rikanmofo thread starter macrumors 65816

    Joined:
    Jan 31, 2003
    #3
    Sigh, I really don't want to resort to that route. I would hate to reset my iPhone and set it up as new again. :( Oh well, guess I won't be using runkeeper and other certain apps then.
     
  4. TypeMRT macrumors 6502

    Joined:
    Sep 7, 2007
    #4
    DEFINTELY try deleting the music and then rebooting the iPhone & watch. It's the only thing that's worked without setting up the iPhone as new. I'm excited to finally be able to use third-party apps and complications.
     
  5. menace3 macrumors 6502

    menace3

    Joined:
    Aug 13, 2008
    Location:
    Seattle, WA
    #5
    I have the exact same issue. And I also tried the removing music steps and nada. I wish there was something that made these work. I do not want to call my watch useless, but I do miss being able to use a lot of my apps.
     

Share This Page