Running Wine, HEC RAS, getting runtime error '339'

Discussion in 'Windows, Linux & Others on the Mac' started by aerlenbach, Apr 9, 2013.

  1. aerlenbach macrumors newbie

    Joined:
    Feb 8, 2011
    #1
    I've got a 2009 MBP, running Mountain Lion.
    I'm an Environmental Engineering major, and I need to run HEC HMS.
    So since I'm too poor for parallels, and too lazy to partition my hard drive, a fellow apple user student suggested I get Wine. I got it, and XQuarts to run X11.
    So HEC HMS works just fine, but later in the semester, I needed HEC RAS.
    So just like HEC HMS, I downloaded HEC RAS from the website, and when I installed it through Wine, i get the error

    Runtime error '339':

    Component 'THREED32.OCX' or one of its dependancies not correctly registered: a file is missing or invalid.

    I googled the problem, and people said to download "THREED32.OCX" and put it in the System 32 folder. So i downloaded "THREED32.OCX", and through X11, I put it in the System 32 folder. However, it still didn't solve the problem, and it still gives me the same runtime error. Is there some special way to install the "THREED32.OCX" file thing? What am I doing wrong??

    Please help!
     
  2. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #2
    Did you looks to see if the program is compatible to wine?
    http://appdb.winehq.org/index.php

    Also did you look into running virtualbox, while you have to supply your own windows install, the virtualization software is free
     
  3. tuns1999 macrumors newbie

    Joined:
    Apr 15, 2013
    #3
    aerlenbach, I was having the same issue in Ubuntu and found your post from google.

    First I was trying to install hec-ras just like you with wine on my ubuntu system and received the same error.

    What you need to do is install the "winetricks" script on your system (google it or go to the wine forums, it was already installed in ubuntu)

    then run "winetricks mfc40"

    for me when the script runs it tries to download the files mfc40.cab and ole2v.exe but fails due to bad urls.

    So what you need to do is manually download the files and place them in the folder "~/.cache/winetricks/mfc40/

    I was able to find them via ftp at ftp.microsoft.com/Softlib/MSFILES/OLE2V.exe and mfc40.cab, if that doesn't work google for the files and you will find them eventually.

    on OS X curl should probably work

    you also need to rename OLE2V.exe to ole2v.exe (OS X and ubuntu are picky about case and windows is not)

    Ok now that you have the files ole2v.exe and mfc40.cab in the "~/.cache/winetricks/mfc40/" folder run "winetricks mfc40" again. It should work this time. After that I was able to launch hec ras.

    Hope this helps.
     
  4. erkn49 macrumors newbie

    Joined:
    Jun 7, 2013
    #4
    HECRAS Missing Reach Data Error

    Hi. I've successfully installed HECRAS 4.1 on my MBP running Snow Leopard with winetricks mfc40. However, when I run hydraulic computations on models involving junctions, HECRAS reported missing reach data and stopped computations. I believe some other winetricks are missing.

    Anyone out there who can provide a clue, please?

    Many thanks in advance!
     
  5. jessicalee_04 macrumors newbie

    jessicalee_04

    Joined:
    Mar 14, 2016
    #5

    did you every figure this out? I am having the same issue.
     

Share This Page