RX 580 Installed, PCI Error Question

Discussion in 'Mac Pro' started by Gazember, May 11, 2017.

  1. Gazember macrumors member

    Joined:
    Apr 5, 2017
    #1
    I have been running the Sapphire Pulse RX 580 8GB since last weekend and I am surprised how well it has been working in FCPX. The performance is very good for my needs. Based on export times I would say it is twice as fast as my trusty old HD 7950 card. Also, my timeline can handle 4K footage sooo much better than before, without stuttering. I don't have time for games so I cannot report on that.

    However, I am getting that "Error gathering PCI information" message in system report. Is there a way to fix that?

    Thank You

    P.S.: Many Thanks to this community for all the great information shared on Mac upgrades.
    --- Post Merged, May 11, 2017 ---
    One more thing, this card makes Da Vinci Resolve usable all by itself! I could not believe the difference from the 7950. It was really struggling before the switch. Then I checked on the Black Magic Design forum and people report performance on par with the 1080 Ti.
     
  2. Fl0r!an macrumors 6502a

    Joined:
    Aug 14, 2007
    #2
    The PCI error is normal when using stock PC cards. It's just cosmetic though, no need to worry.
     
  3. Gazember thread starter macrumors member

    Joined:
    Apr 5, 2017
    #3
    Thanks for the clarification. This GPU upgrade has given my setup another two years of life. The SSD updates were noticeable changes, but the GPU made the biggest difference for FCPX work. It is a great relief not having to shell out three to four grand on a new setup right now!
     

Share This Page