S.O.S. internet speed

Discussion in 'iMac' started by ScoutA, May 28, 2011.

  1. ScoutA macrumors newbie

    Joined:
    May 28, 2011
    #1
    In the three weeks since I've had my 27" imac, I've noticed increasingly slow internet speeds. My Airport has all bars, and my Mac Air is working great. What to do? This is custom-configured, box thrown away, and panic setting in!
     
  2. rjohnstone macrumors 68040

    rjohnstone

    Joined:
    Dec 28, 2007
    Location:
    PHX, AZ.
    #2
    We're having a similar issue with a brand new 21.5" iMac.
    Wired or wireless makes no difference, internet speeds sucked.
    I turned off the automatic settings and manually configured the network card to 100 base (1000 is moot since my internet connection is only 10Mbps) and set flow control to full duplex only.
    Really helped a ton.
    I use a wired connection, but I suspect you can make similar adjustments to your WiFi settings.
     
  3. ScoutA thread starter macrumors newbie

    Joined:
    May 28, 2011
    #3
    :eek: Thanks so much, but please, could you translate that into actual steps?
     
  4. daneoni macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
  5. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #5
    I assume it's not a network problem...

    Have you checked download speeds, reception on another computer, iPhone etc?
     
  6. Csory macrumors newbie

    Joined:
    May 10, 2011
    Location:
    Fairfax, VA
    #6
    5Ghz bug?

    In my case it was the "5GHz bug" with the mid-2011 iMacs. Limiting my base station to 2.4GHz bands solved (khm... circumvented) the problem. Now waiting for a firmware update :(
     

Share This Page