S2 Portable Hard Disk Not Detectable / Working

Discussion in 'Mac Accessories' started by Recluded, May 6, 2010.

  1. Recluded macrumors newbie

    Apr 24, 2010
    Hi all , i have a problem with my Samsung S2 Portable External Hard Disk capacity : 500 GB . Once i plugged my Samsung S2 Portable External Hard Disk capacity : 500 GB into my usb port , it started spinning , no weird sounds but it was spinning without blinking , but after awhile , it stopped spinning . The external hard disk could not be mounted and was not even shown on my disk utility . I was using Snow Leopard on my external hard disk when i accidentally shift the table and the Hard disk was disconnected with from my usb with the usb cable was still connected to my port . Can anyone help me ? I tried DiskWarrior but DiskWarrior still cannot find my external hard drive . can anyone help me ???? Please , i really need help .

    Help needed ,
  2. zarathustra macrumors 6502a


    Jul 16, 2002
    Philadelphia, PA
    Maybe your drive is not getting enough power?

    I have a Seagate portable drive and it behaves the way you described if I don't use the included 2 into 1 USB cable (it uses 2 usb ports on your machine, and a mini usb for the drive).

    Sometimes there could be a peak in the power required by the hard drive and the OS will either shut down the port and you get a message about it; other times the HD will just power down and refuse to run.

    Hope it's as simple as that.
  3. Recluded thread starter macrumors newbie

    Apr 24, 2010
    I have a y cable provided .The hard disk spins for a while and stop spinning after like 1 minute , same goes to it when i plug it into windows. The y cable have 2 usb plugs and i ussually plug the one which have another usb plug leading to it, but when i plug both plug in , nothing happens , it still power down after awhile . The problem is that it does not blink !

    Any kind soul willing to help me ?

    Help needed very much ,

Share This Page