Safari 10 Crashing?

Discussion in 'OS X El Capitan (10.11)' started by JohnDS, Sep 21, 2016.

  1. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #1
    Ever since I downloaded yesterday's update to Safari 10, Safari has been regularly crashing without even bringing up the crash reporter.

    Is anyone else having this problem?
     
  2. StephenBeckwith macrumors newbie

    Joined:
    Jul 24, 2002
    Location:
    Allentown, PA
    #3
    El Capitan latest version, crashes many times, much more UNSTABLE> 2011 vintage 15" MBP w/8G RAM and HDD. Previous version was being a bit more flakey than normal, could be system issue, but this update is definitely more unstable.
     
  3. dogslobber macrumors 68020

    dogslobber

    Joined:
    Oct 19, 2014
    Location:
    Apple Campus, Cupertino CA
  4. maxsix Suspended

    maxsix

    Joined:
    Jun 28, 2015
    Location:
    Western Hemisphere
    #5
    My Safari experience has been fine.

    My Chrome experience continues to be outstanding. It's speed, functionality and cross platform compatibility makes it my default choice for all my smartphones, tablets and computers.
     
  5. Hawaiian Starman macrumors member

    Joined:
    Oct 27, 2001
    #6
    Via Safari preferences, check your Flash plug-in settings via Security>Plug-in Settings. Perhaps the crash is occurring due to Flash version or certain web sites requiring Flash. I have my Flash settings set to "Allow" and stop flash via the ClickToFlash extension.
     
  6. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #7
    I have temporarily deleted all plug-ins and extensions and will see what happens. If this cures the crashing, I will add them back in as needed.
     
  7. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #8
    Okay. Still happening. I have deleted all plug-ins and extensions except the three Apple says to leave (https://support.apple.com/en-us/HT203353).

    I have verified my disk using Disk Utility (no errors) and repaired permissions using Onyx. I have also deleted all caches, etc. using Onyx.

    The crash reporter says:

    Crashed Thread:

    0 Dispatch queue: com.apple.main-thread

    Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    0 libdispatch.dylib 0x00007fff8ae3464a _dispatch_alloc_continuation_free + 83
    1 libdispatch.dylib 0x00007fff8ae41c6a _dispatch_main_queue_callback_4CF + 1763
    2 com.apple.CoreFoundation 0x00007fff906fd9e9 __CFRUNLOOP_IS_SERVICING_THE_MAIN_DISPATCH_QUEUE__ + 9
    3 com.apple.CoreFoundation 0x00007fff906bc8dd __CFRunLoopRun + 1949
    4 com.apple.CoreFoundation 0x00007fff906bbed8 CFRunLoopRunSpecific + 296
    5 com.apple.HIToolbox 0x00007fff8ef38935 RunCurrentEventLoopInMode + 235
    6 com.apple.HIToolbox 0x00007fff8ef3876f ReceiveNextEventCommon + 432
    7 com.apple.HIToolbox 0x00007fff8ef385af _BlockUntilNextEventMatchingListInModeWithFilter + 71
    8 com.apple.AppKit 0x00007fff94cd0df6 _DPSNextEvent + 1067
    9 com.apple.AppKit 0x00007fff94cd0226 -[NSApplication _nextEventMatchingEventMask:untilDate:inMode:dequeue:] + 454
    10 com.apple.Safari.framework 0x000000010a2a35b6 -[BrowserApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 252
    11 com.apple.AppKit 0x00007fff94cc4d80 -[NSApplication run] + 682
    12 com.apple.AppKit 0x00007fff94c8e368 NSApplicationMain + 1176
    13 libdyld.dylib 0x00007fff8426c5ad start + 1​


    Any thoughts?
    --- Post Merged, Sep 24, 2016 ---
    P.S. I think the next thing I will try is to download and run the OS 10.11.6 combo update, although I am already at 10.11.6. It may replace and foozled components.
     
  8. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #9
    So much for that idea. The combo installer won't install. Says "the volume does not meet the requirements for this update", presumably because 10.11.6 is already installed. (This is a late 2013 MacBook Pro Retina).
     
  9. JohnDS, Sep 24, 2016
    Last edited: Sep 24, 2016

    JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #10
    I may have it fixed. In addition to the above, I went to Safari/Preferences/Advanced, enabled the Develop menu, then Empty Caches.

    Then I went to ~/Library/Caches/com.apple.Safari/ and deleted the cache files.

    Finally, I deleted ~/library/Preferences/com.apple.Safari.Extensions.plist
     
  10. rGiskard macrumors 68000

    rGiskard

    Joined:
    Aug 9, 2012
    #11
    Yes, the Safari 10 update broke Safari for me on El Cap. When Safari launches (with previous tabs, about two dozen) it fails to load more than the front tab, then the beachball spins. My entire system is then hosed. No other apps will launch or quit. I must do a hard shutdown and reboot. Then everything works fine until a launch Safari.

    Deleting caches via your method seems to work so far. I'll update after some more testing.
     
  11. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
  12. rGiskard, Sep 24, 2016
    Last edited: Sep 24, 2016

    rGiskard macrumors 68000

    rGiskard

    Joined:
    Aug 9, 2012
    #13
    Same here, Safari still hoses my system when running. I cannot launch any apps so no Activity Monitor or Terminal diagnostics.

    Edit: All network activity is s l o w.
     
  13. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #14
    Mine is a bit different. Only Safari quits. Everything else is okay. And it seems to happen mostly when I try to open a bookmark.
     
  14. rGiskard macrumors 68000

    rGiskard

    Joined:
    Aug 9, 2012
    #15
    Have you done extension troubleshooting? I disabled all and still had the problem. Then re-enabled all but Wiper, instead enabling Nope for ad blocking.

    It doesn't make any sense, but now the problem seems to have stopped. I'll report if I find anything else.
     
  15. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #16
    I removed all extensions and plug-ins except for the Apple plug-ins.
    --- Post Merged, Sep 24, 2016 ---
    I am thinking maybe it is a corrupt bookmarks.plist file since opening bookmarks seems to cause the crash, so I have now used Time Machine to replace the Bookmarks.plist file with one that is three weeks old. Will see how that works.
    --- Post Merged, Sep 24, 2016 ---
    I have also unchecked "include Safari suggestions" in the Search tab of the Safari prefs following a suggestion on the Apple Discussion Forums.
     
  16. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #17
    I tried doing this recently for a different prob and got the same error. Only way I was able to reinstall 10.11.6 was to download the installer from the App Store and run it.
     
  17. rGiskard macrumors 68000

    rGiskard

    Joined:
    Aug 9, 2012
    #18
    How did you download the El Cap installer from the App Store? I cannot find it and links to it are all dead since the macOS Sierra release.
     
  18. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #19
    I thought I had read somewhere that Apple was going to keep El Cap in the App Store? I'll have to look into that.

    If you previously downloaded El Cap, it will show in the Purchased tab in the App Store.
     
  19. rGiskard macrumors 68000

    rGiskard

    Joined:
    Aug 9, 2012
    #20
    I can download a couple older versions, but El Cap says "downloaded". I guess I need to update to macOS Sierra to download El Capitan. I was going to wait but I guess now is the time to do a clean install the new OS.

    Oddly enough my problems mysteriously vanished. All I did was turn off all installed Safari Extensions (problem persisted), then turn them back on one at a time (problem persisted), then switch of Wipr and turn on Nope, then Nope off and Wipr back on for the same Extensions as originally running (problem vanished, then returned). After an hour or so of using and quitting Safari the problem vanished.

     
  20. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #21
    Unchecking "include Safari suggestions" in the Search tab of the Safari prefs seems to have solved the problem.
     
  21. simon lefisch macrumors 6502a

    simon lefisch

    Joined:
    Sep 29, 2014
    #22

    Maybe you already have the installer downloaded then. Check your Applications folder for the installer. I'm on El Cap and can download the installer if needed.
     
  22. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #23
    Actually, my problem persists and I think the problem is the Adobe Flash plug-in. I am going to delete the current version (ver. 23) and revert to the previous version (ver. 22) and see if that helps.
     
  23. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #24
    So far no more crashes after reverting to Flash ver. 22.
     
  24. JohnDS thread starter macrumors 65816

    Joined:
    Oct 25, 2015
    #25
    Started crashing again. I discovered that the Adobe auto-update had updated me to ver. 23 again. Reverted to ver. 22 and deleted the auto-update daemon. No more crashes. So there is no question that the problem is ver. 23 of Flash.
     

Share This Page