safari 4.0.1 and new tab oddity

Discussion in 'Mac Apps and Mac App Store' started by flapperdink, Jun 30, 2009.

  1. flapperdink macrumors member

    Joined:
    Jan 25, 2009
    #1
    i've noticed something quite odd with safari and the opening of a new tab (done via cmd+t). also, my homepage is set to google.com.

    so here's the issue: if i have only one tab open and i use the cmd+t to open a second tab, the selected field will default to the address bar...but when i open a subsequent tab (i.e. third, fourth, fifth, etc.) then the selected field will default to the google search engine input field.

    now this may seem like a moot point, but it drives me insane. i usually only have one tab open and when i have something else i want to run a search on, i open a new tab using cmd+t then start typing away and press return. the only issue is that when i do this for the second tab it defaults to the address bar.

    anyone else run into this? i don't if this is how safari has always been since i've only really started using it on 4. i've been a FF guy before and FF would always default to the google search engine input field.

    it's not necessarily a defect, but just an oddity that interferes with my normal routine of using a web browser. it bugs me.
     
  2. Tallest Skil macrumors P6

    Tallest Skil

    Joined:
    Aug 13, 2006
    Location:
    1 Geostationary Tower Plaza
    #2
    I can report that this does not happen to me.
     
  3. flapperdink thread starter macrumors member

    Joined:
    Jan 25, 2009
    #3
    that's weird. i tested this many of times. completely closing safari and opening a new session...same results every time. :confused:

    i know these mac apps are fairly customizable via terminal...is there any way possible to force the selected field on opening a new tab? i'm assuming the answer to be 'no' but i guess it's worth asking.
     

Share This Page