Safari 4.0.3 does not launch

Discussion in 'Mac Apps and Mac App Store' started by The General, Aug 11, 2009.

  1. The General macrumors 601

    Jul 7, 2006
    I installed the update through Software Update and it refuses to launch. I tried downloading the installer from and installing it, that didn't work. I've tried repairing disk permissions, that did not work. I've tried deleting Safari and redownloading the installer and reinstalling it and it didn't work.

    What do I have to do in order to get Safari 4.0.3 to launch?
  2. celticpride678

    Feb 15, 2009
    Boston, MA
    I think that your only choice is to Archive and Install and not install Safari 4.0.3 from Software Update. I am not aware of any way to downgrade. Instead of playing around with it and trying different things, just try that.
  3. jpetreanu macrumors newbie

    May 7, 2009
    Same problem. updated to Sfari 4.0.3 and it does not open a window, even clicking New Window. Clicking a bookmarks from the menu bar open a almost blank useless window

    Help Apple !!!!


Share This Page