Safari 4 Beta crashes instantly

Discussion in 'Mac Apps and Mac App Store' started by ethical, Feb 24, 2009.

  1. ethical macrumors 68000

    Joined:
    Dec 22, 2007
    #1
    Hi guys,

    I just downloaded Safari 4 beta from the apple site, installed it, restarted etc and everytime I launch it it crashes instantly. So, I uninstalled it (using the uninstaller), restarted, installed it, restarted again and still have the same problem. I've turned Growl off because I've heard this causes issues with some applications. Got any ideas?

    Thanks,

    Luke
     
  2. mknawabi macrumors 6502

    mknawabi

    Joined:
    Feb 5, 2006
    Location:
    Irvine, CA
    #2
    Go to console and check your crashreporter log. If you see something there, report it to Apple.
     
  3. ethical thread starter macrumors 68000

    Joined:
    Dec 22, 2007
    #3
    ok, i dont really know what im looking for. anyone else having the same problem?
     
  4. mikey.f macrumors regular

    Joined:
    Aug 18, 2006
    Location:
    Slovakia
    #4
    Hi, I'm having the same issue. I am a developer and had a Safari 4 dev.preview installed before that, so I uninstalled all of it, basically went through the same procedure with the restarts as you did, and it is crashing each time I try to open! :-(

    Here's some info from the crash report that might be relevant:

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000020
    Crashed Thread: 0

    Thread 0 Crashed:
    0 libobjc.A.dylib 0x9700e688 objc_msgSend + 24
    1 libobjc.A.dylib 0x97006bdf call_load_methods + 214
    2 libobjc.A.dylib 0x970000d3 load_images + 98
    3 dyld 0x8fe02e38 dyld::notifySingle(dyld_image_states, mach_header const*, char const*, long) + 328
    4 dyld 0x8fe0e7cf ImageLoader::recursiveInitialization(ImageLoader::LinkContext const&, unsigned int) + 287
    5 dyld 0x8fe0e8c9 ImageLoader::runInitializers(ImageLoader::LinkContext const&) + 57
    6 dyld 0x8fe02202 dyld::runInitializers(ImageLoader*) + 34
    7 dyld 0x8fe0bbdd dlopen + 605
    8 libSystem.B.dylib 0x90b65202 dlopen + 66
    9 com.apple.CoreFoundation 0x908e6863 _CFBundleDlfcnLoadBundle + 307
    10 com.apple.CoreFoundation 0x908e7187 _CFBundleLoadExecutableAndReturnError + 567
    11 com.apple.Foundation 0x905a8b73 _NSBundleLoadCode + 259
    12 com.apple.Foundation 0x905a82db -[NSBundle loadAndReturnError:] + 331
    13 com.apple.Foundation 0x905a818a -[NSBundle load] + 42
    14 com.apple.Foundation 0x905a814d -[NSBundle principalClass] + 45
    15 com.apple.AppKit 0x9683c7fd -[NSInputManager _loadBundle] + 137
    16 com.apple.AppKit 0x9683bf9a -[NSInputManager initWithName:host:] + 2639
    17 com.apple.AppKit 0x96394525 +[NSInputManager initialize] + 1134
    18 libobjc.A.dylib 0x96fff8b8 _class_initialize + 367
    19 libobjc.A.dylib 0x96ffe239 _class_lookupMethodAndLoadCache + 81
    20 libobjc.A.dylib 0x9700e6d6 objc_msgSend + 102
    21 com.apple.AppKit 0x963933a3 -[NSApplication run] + 83
    22 com.apple.AppKit 0x963608a4 NSApplicationMain + 574
    23 com.apple.Safari 0x00003306 0x1000 + 8966


    I am going to try to disable some of the plug-ins to see if they could be causing this issue.
     
  5. mknawabi macrumors 6502

    mknawabi

    Joined:
    Feb 5, 2006
    Location:
    Irvine, CA
    #5
    Maybe try deleting com.apple.Safari.plist from ~/Library/Preferences/
     
  6. Lava Lamp Freak macrumors 65816

    Joined:
    Jun 1, 2006
    #6
    I have the same problem and finally gave up. I don't have any plug-ins installed. I don't even use Safari. I have no idea what the problem is, but there are others who have been reporting the same problem in the big Safari 4 thread.

    Update: It turned out to be 1Password for me. After updating the Supported Browsers file I was able to launch Safari.
     
  7. mikey.f macrumors regular

    Joined:
    Aug 18, 2006
    Location:
    Slovakia
    #7
    I know that much, but thanks. It didn't work. :confused:
     
  8. tlambert03 macrumors newbie

    Joined:
    Feb 24, 2009
    #8
    I had the same problem at first, here's how I fixed it:

    I backed up everything from the folders HD/Library/InputManagers and HD/Library/internet Plug-ins to a folder on my desktop and then removed everything from those two folders. then I installed the Safari4Beta and I restarted my computer. Safari worked. Then I returned each plugin and input manager one by one to their folders in HD/Library/. . .

    oddly enough, I have now replaced them all and the beta still works. so that's weird.

    For what it's worth, the input managers that I have installed (and may have been causing problems) are 1password, multiclutch, safariblock, and glims.

    also, safariblock and glims no longer work or show up in the preferences of Safari 4.

    have you checked your input managers folder for potential culprits...
     
  9. crazzyeddie macrumors 68030

    crazzyeddie

    Joined:
    Dec 7, 2002
    Location:
    Florida, USA
    #9
    I have read that if you have any InputManagers installed that the beta will crash... try removing those from the ~/Library/ folder.
     
  10. Lava Lamp Freak macrumors 65816

    Joined:
    Jun 1, 2006
    #10
    I finally got mine to launch after updating the Supported Browsers file in the 1Password resources folder. Unfortunately, now Safari crashes any time I open more than tab.
     
  11. mikey.f macrumors regular

    Joined:
    Aug 18, 2006
    Location:
    Slovakia
    #11
    Thanks for your suggestion. I just disabled my Speed Download safari plug-in, and suddenly everything works.
     
  12. tlambert03 macrumors newbie

    Joined:
    Feb 24, 2009
    #12
    just an extra note: sometimes there are inputmanagers in the MacintoshHD/Library/ folder (as opposed to the user library folder mentioned here) . . . be sure to check both places if you're still having a problem!
     
  13. Lava Lamp Freak macrumors 65816

    Joined:
    Jun 1, 2006
    #13
    Thanks for the info. After trying this I got Safari working. It turned out that I had an old plug-in installed from back when I was using Safari long ago.
     
  14. Leech macrumors newbie

    Joined:
    Feb 24, 2009
    #14
    I've just removed Glims from that InputManagers and now it works.
     
  15. raisen macrumors newbie

    Joined:
    Feb 11, 2009
    #15
    Add me to the list.. not only I wasn't able to open Safari, but I wasn't able to run Mail and Skype either. Firefox ran fine though. I didn't try any other programs and went back to Safari v3
     
  16. QuantumLo0p macrumors 6502a

    QuantumLo0p

    Joined:
    Apr 28, 2006
    Location:
    U.S.A.
    #16
    Same for XP Pro

    Safari 4 crashed immediately on my Windows XP Pro CAD workstation. I think I tried to interrupt the "WELCOME TO SAFARI 4" splash screen spectacular and it didn't like it.

    I think I'm going to wait for some bug fixes and security updates.
     
  17. tomoliveri macrumors newbie

    Joined:
    Jan 11, 2009
    #17
    huzaah!

    Deleting the input managers fixed the problem instantly!

    Looks like its only going to punish people who already used safari!

    Apple best fix this epic blunder up asap.
     
  18. tikabanget macrumors newbie

    Joined:
    May 26, 2009
    #18
    thanx... ^^

    i tried your steps.. and it works..!!!
    thanx so much..;)
     

Share This Page