Safari 4 + GreaseKit

Discussion in 'Mac Basics and Help' started by eleven7, Jun 21, 2009.

  1. eleven7 macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #1
    Has anyone had any luck running greasemonkey scripts in Safari 4 using GreaseKit?

    I'm enjoying Safari 4, it made me switch back from Firefox, but I would really like to be able to run the link checker script that I've been using with firefox/greasemonkey for a while.

    Anyone using greaseKit with Safari 4 successfully or know of a compatible link checker plugin?
     
  2. MKnight macrumors regular

    MKnight

    Joined:
    Oct 15, 2007
    #2
    Have you done some Google searching?

    http://www.simplehelp.net/2007/11/14/how-to-run-greasemonkey-scripts-in-safari/



     
  3. eleven7 thread starter macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    Japan
    #3
    Did you read my post?

    I know how to use GreaseKit, which is why the thread title is Safari 4 + GreaseKit

    What I want to know is, if someone has got GreaseKit to work with Safari 4. That article and that same version of greaseKit has been around since 2007, well before Safari 4 was released.

    It may be just that the old script I'm running doesn't work, which is why I asked if anyone has had any luck :)
     
  4. buckhunter534 macrumors newbie

    Joined:
    Sep 30, 2009
    #4
    I am having the same problem, I haven't found anything that works yet...
     
  5. seenevil7 macrumors newbie

    Joined:
    Nov 4, 2009
    #5
    greasekit works on install

    greasekit worked for me. (some scripts)..
    but the problem i have is i cant get it to launch on restart of safari 4...
    im running in 32 bit mode using SIMBL .... for some reason i think it is incompatible with other pluggins ...when i try to reinstall (replace) while safari is open it says greasekit is in use but there are no styles or menu to manage them and it doesnt let you install scripts.. when i close safari and re-install it shows up!... i will try it again and see if any other pluggins are disabled ( i think cooliris might be the problem, not sure).. i have safaristand, safari adblock, glims, pdf browser, clicktoflash, and then when i installed inquistor3 it crashes and on right start no greasekit!!! how do i remove inquistor3?? or does anyone have any thoughts on whats going on here???

    thanks

    I am running
    Mac OS X 10.6.1 2.4GHz Intel Core 2 Duo 4 GB 667 MHz DDR2 SDRAM
    Apple Airport extreme base station
    LaCie BigDisk Extreme+ partitioned for Time Machine
    Secondary LaCie 1 TB external
     
  6. seenevil7 macrumors newbie

    Joined:
    Nov 4, 2009
    #6
    ok i deleted any thing i found in my HD that said inquisitor3 and reinstalled greasek

    ok i deleted anything i found in my HD that said inquisitor3 and reinstalled greasekit it works again !!!! i have restarted several times no more problems...


    OK i take that back..... i still have inquisitor installed somehow...but greasekit now works....
    i guess you must install inquisitor3 first then greasekit!!
     
  7. sammich macrumors 601

    sammich

    Joined:
    Sep 26, 2006
    Location:
    Sarcasmville.
    #7
    I had GreaseKit installed before and had the menu item appear in the menu bar. I had wanted to run some Mafia Wars (yeah I know...) scripts but they didn't end up working.

    So I deleted it because WebKit was giving out these annoying warnings.
     
  8. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #8
    What's with the attitude? MKnight was just trying to help you. Despite your apparent belief that the rest of us are clairvoyant, there is nothing in your original post, or it's title, to indicate your level of expertise.

    Did you notice on the linked page that there is another link to a discussion board? Maybe you'll find the answer if you post there, as others who use GreaseKit might be looking in.

    Relax. Be polite. It will get you farther.
     
  9. mondaiguy macrumors newbie

    Joined:
    Jan 9, 2010
    #9
    Hey Gregg2, I know this is an old thread, but the thread starter gave MKnight attitude because MKnight gave him attitude first. And MKnight linked him to an article that had nothing to do with his question.

    He clearly asked for help on getting GreaseKit to work with Safari 4. Emphasis was on Safari 4.

    Before you tell other people to be polite, maybe you should ask yourself if you're being polite, because you came off like a jerk in your post.

    I'm also having trouble getting GreaseKit to work in Safari 4. It worked fine in Safari 3.
     
  10. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #10
    I take it you haven't found a solution. Maybe they need to update it or something.
     
  11. pixauth macrumors newbie

    Joined:
    Mar 26, 2010
    #11
    Possible solution...

    I know part of the issue had to do with running a 64bit specific GK 1.7, using OSX 10.5.8 and Safari 4 (my current setup). Solved the problem by downloading a recompiled version here: http://code.google.com/p/greasekit/issues/detail?id=38#c19 (check out freewizard's link in comment #7.) I'm now running Greasekit and Glims side by side with no issues - hope this helps. BTW, for all of you who don't think GK and your scripts are working, they should be working just fine, it just seems to be an issue with the menu not showing. If you want to check, go to Activity Monitor and inspect Safari's Open Files and Ports. You should see both GK and SIMBL running just fine.
     

Share This Page