Safari 4 Snow Leopard Bug

Discussion in 'Mac Basics and Help' started by philiporeilly, Oct 28, 2009.

  1. philiporeilly macrumors newbie

    Joined:
    Jun 28, 2008
    #1
    I've been having problems with Safari 4 since I upgraded to Snow Leopard. Any page that displays HTML source code in a standard page jumbled up. It is not rendering the page correctly, although if I copy the scrambled text to another program it displays correctly. This only effects Safari and other browsers are okay.

    Does anyone have a suggestion how I can reinstall safari / reset??

    [​IMG]

    The screenshots above are from a Joomla Edit HTML page but this also happens on other pages such as where they show sample HTML code tutorials.
     
  2. dedwarmo macrumors newbie

    dedwarmo

    Joined:
    Oct 13, 2009
    #2
    Safari 4 Snow Leopard Bug

    I get the same problem. It seems to happen to text that is inside the <pre> tag or <code> tag. If you check the page source you'll see that the garbled text is between these tags. Here is a link to a very simple page which demonstrates the problem. If you view the page with Firefox you won't see a problem.

    http://davidmo.com/bugs/bug.html
     
  3. Aniday macrumors regular

    Joined:
    Jan 27, 2009
    #3
    I’m seeing that page correctly with the letters a-y in Safari 4. Guess the bug doesn’t effect everyone.
     
  4. catinthecorner macrumors newbie

    Joined:
    Oct 29, 2009
    #4
    safari bug

    just installed snow leopard and i'm also having problems with safari.... firefox no problem.....
    as the previous poster said" I've been having problems with Safari 4 since I upgraded to Snow Leopard. Any page that displays HTML source code in a standard page jumbled up. It is not rendering the page correctly, although if I copy the scrambled text to another program it displays correctly. This only effects Safari and other browsers are okay.


    what to do???
     
  5. dedwarmo macrumors newbie

    dedwarmo

    Joined:
    Oct 13, 2009
    #5
    Safari 4 Snow Leopard Bug

    Thanks for checking. I registered as a developer on the Apple website and reported the bug and they said I was having some other problem with my fonts or something. If I have a font problem why would it only show up in Safari and only affect text inside the <pre> or <code> tags?
     
  6. philiporeilly thread starter macrumors newbie

    Joined:
    Jun 28, 2008
    #6
    Got advice on solution from a user on appleinsider forums. The issue is caused by corrupt Application Cache files in -/library/cache folders

    If you delete all cache files in the Library folder, all is okay again. An easier solution is to download the free app Snow Leopard Cache Cleaner which will delete the necessary caches with one click.
     
  7. dedwarmo macrumors newbie

    dedwarmo

    Joined:
    Oct 13, 2009
    #7
    Safari 4 Snow Leopard fixed width font problem

    I used Snow Leopard Cache Cleaner to delete the entire contents of the cache folders as you can see in this screen shot. Still no success.

    [​IMG]

    This is what I see on pages with text inside the <pre> or <code> tags:

    [​IMG]
     
  8. dedwarmo macrumors newbie

    dedwarmo

    Joined:
    Oct 13, 2009
    #8
    Safari 4 Snow Leopard Courier Font Problem

    I refused to believe that it was a font problem, but I finally decided to open up Font Book.app. It turns out there were duplicate copies of the Courier font. I tried removing the font and it wouldn't let me remove it. I logged out and logged back in under my administrator account. I was then able to remove the duplicate font using Font Book.app. Now text that is supposed to be displayed using the Courier font (including text inside of the <pre> and <code> tags) displays correctly.
     

Share This Page