Safari 5.0.3 issues?

Discussion in 'Mac Apps and Mac App Store' started by mac2x, Nov 26, 2010.

  1. mac2x macrumors 65816

    Joined:
    Sep 19, 2009
    #1
    To make a long story short, Safari has been good to me for the most part ever since I started using Macs. No major issues.

    Just now I tried to quit it. At the time it was using ~500 MB physical memory. As soon as I hit the quit button, it beachballed and my whole machine slowed down to a crawl as the "not responding" application used massive amounts of CPU (it was registering at more than 200%, and I only have two cores (!) ).

    Fortunately I was finally able to kill it from terminal. This is literally the first time Safari has done something like this to me. Any ideas on what might have caused it? The only major change recently was the 10.6.5 update.
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    When things like this happen, the first thing an experienced user does is read log files from just before the event of interest. In Mac OS X this is done from the Console application, in Applications -> Utilities. It also helps to filter the logs to show only events from the relevant application, in this case Safari. To do that with Console, just type Safari in the search for box.
     
  3. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #3
    :D

    Code:
    11/26/10 11:01:06 AM	[0x0-0x15015].com.apple.Safari[290]	Threw error #201 (XML parsing failure) in CreatePropertiesFromXMPData()
    **repeated about 50 times**

    Code:
    11/26/10 11:08:02 AM	[0x0-0x15015].com.apple.Safari[290]	Fri Nov 26 11:08:02 <machine name>.local Safari[290] <Error>: kCGErrorIllegalArgument: CGSGetSurfaceBounds
    11/26/10 11:08:02 AM	[0x0-0x15015].com.apple.Safari[290]	Fri Nov 26 11:08:02 <machine name>.local Safari[290] <Error>: unknown error code: invalid drawable
    **both repeated several times**

    And when I terminated it:

    Code:
    11/26/10 11:20:27 AM	com.apple.launchd.peruser.501[209]	([0x0-0x15015].com.apple.Safari[290]) Exited: Terminated
    I terminated a minute or so after it hung up. I guess the connections between the previous messages and the hang up aren't obvious to me.
     
  4. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #4
    I haven't seen that error before, though I can suggest some common troubleshooting tactics:
    1. Move the com.apple.Safari.plist file elsewhere (while Safari isn't running) then restart Safari.
    2. Clear the cache.
    3. Reset Safari.
    4. Restart your Mac.

    The plist file is located in /Users/username/Library/Preferences, where username is your short user name.
     
  5. mac2x thread starter macrumors 65816

    Joined:
    Sep 19, 2009
    #5
    I trashed the plist and reset Safari. All seems well. Thanks!
     

Share This Page