Safari 5.1.1 problems

Discussion in 'Mac Apps and Mac App Store' started by Dry Rot, Oct 12, 2011.

  1. Dry Rot macrumors member

    Joined:
    Apr 28, 2009
    Location:
    Australia
    #1
    Just downloaded the latest Safari 5.1.1 and am running the latest Snow Leopard OS.

    Safari was fine before the last update but now has gone very weird:

    1. I've lost my reading list. The button is still there, the left hand side of the browser moves left to right, but no reading list appears.

    2. My Top sites page has gone weird too. I use a 6 x 4 grid and it worked fine before. Now it's stretched horizontally, cutting off the far right hand column of sites. More bizarre, scrolling over the page shows the urls of the sites as they were previously set up, so as you scroll over to the right, the url doesn't match the indicated site.

    Anyone else have these problems with Safari 5.1.1 and Snow Leopard.

    Would appreciate any help fixing this madness.

    ----------

    If anyone else gets this, it seems a series of emptying the cache and restarting Safari a few times fixes it.

    Still interested to know what happened and if anyone had the same problem post updating.
     
  2. vincebio macrumors 6502a

    vincebio

    Joined:
    Jun 27, 2005
    Location:
    Glasgow
    #2
    mines is really pissing me off...

    5.1 was perfect, so i was looking forward to 5.1.1 speed improvements....

    instead ive got a browser that plays video's for around a minute before freezing while the audio still runs.....and the only way to get it to unfreeze is to use expose and back again.

    very weird....never seen an issue like this before.

    ive also got a problem with it stuttering when loading pages and i have to click on the page to get it to keep loading....

    I also just upgraded the flash player just incase it was that but its still happening..


    any ideas anyone?

    i was under the impression that OSX actually stored a copy of your old safari version somewhere during the install, but i cant remember where to find it...
     
  3. Brigrat macrumors member

    Joined:
    Jul 10, 2004
    #3
    I'm having similar problems. When watching video (ESPN 3), it will play for a minute or so, then freeze with just audio...this is an improvement, a little while ago it was locking up my whole system and forcing a reboot. I have switched over to Chrome and everything is working fine. I have been happily using safari for months until this "upgrade."



     
  4. vincebio macrumors 6502a

    vincebio

    Joined:
    Jun 27, 2005
    Location:
    Glasgow
    #4
    ok ive managed to fix mines.

    updated flash, repaired permissions, then cleaned out cache and reset safari twice...logged out and back in again and its working smoothly...

    result!
     
  5. mazz0 macrumors 65816

    mazz0

    Joined:
    Mar 23, 2011
    Location:
    Leeds, UK
    #5
    top cut off, and artifacts

    Mine cuts off the top of sites (such as the menu bar on Google) and the Find bar (cmf+f). I also keep getting artefacts when scrolling, have to zoom in and out to fix them.

    Suppose I'd better log these as bugs with Apple...
     

Share This Page