Safari 5.1 font rendering problem

Discussion in 'Mac OS X Lion (10.7)' started by psychomachine, Jul 7, 2011.

  1. psychomachine macrumors newbie

    Joined:
    Jul 7, 2011
    #1
    Hi,

    Safari 5.1 on Lion GM is rendering some pages illegible, like in the attached image. Looking at the source displays the proper text. Even copying it and pasting it into a text file displays the correct text. But in Safari, it is illegible.

    I have tried clearing the font caches, restarting, but to no avail. My default font encoding in Safari is UTF-8. The page from the attached image is also utf8.

    This happens on some pages -- every day I encounter two or three such pages.

    Anybody noticed anything similar? Any idea what else I could do to fix this.

    All best
    Psych
     

    Attached Files:

  2. CyBeRino macrumors 6502a

    Joined:
    Jun 18, 2011
    #2
    I've had that exactly once and restarting (maybe even rebooting, i don't remember) helped.

    Have you tried in a new user account?
     
  3. psychomachine thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #3
    rebooting doesn't change it for me -- but your hint about trying under a different user name was brilliant!!! i just checked and safari seems to be fine there.

    i tried deleting the safari user preferences in my regular account in the hope that will help, but it didn't

    so my question is now: is there anything else i can do in my regular account to try to fix this. it sounds like a major pain creating a new user account, moving everything there, getting everything set up again... (iTunes, networking, all the files etc...) or am I making it sound worse than it is?
     
  4. CyBeRino macrumors 6502a

    Joined:
    Jun 18, 2011
    #4
    Likely you can get away with deleting your entire ~/Library/Caches folder. I don't think this is a preference problem.
     
  5. etabisco macrumors newbie

    Joined:
    Jul 9, 2011
    #5
    Font issue

    I had the same problem. I did some detective work and the following is what I found (though I admit that what I think I find, I may not be explaining correctly).

    After turning on the developer web inspector on the page where it occurred, it seemed that my system was suddenly lacking a Sans Serif font to default to. In it's absence Safari was defaulting to Last Resort font — which is the boxed A's that you are seeing.

    I activated sets of Helvetica that seemed to be deactivated and the problem went away.
     
  6. psychomachine thread starter macrumors newbie

    Joined:
    Jul 7, 2011
    #6
    dear etabisco,

    thanks for posting your solution. actually, yesterday i bit the bullet and created a new user account for myself (after emptying the caches didn't fix the problem for me).

    but your fix may help others if they run into this problem.

    all best,
    psych
     
  7. capsule9 macrumors newbie

    Joined:
    Jul 21, 2011
    #7
    I turned off all non system helvetica fonts, cleared cache, restarted safari and that worked
     
  8. Jeffrey26 macrumors newbie

    Joined:
    Jul 21, 2011
    #8
    I had "FontAgent" working. After deselecting this program it worked fine for me.
     
  9. atari1356 macrumors 68000

    atari1356

    Joined:
    Feb 27, 2004
    #9
    Digging up a slightly old thread... but I was having the same issue and was able to fix it by editing a certain webkit framework file. Basically, if you're using something like FontExplorer X or FontAgent Pro, you have to edit a file used by webkit, to let it know where some fonts are stored.

    There's information about this fix in this Apple support forum thread:
    https://discussions.apple.com/message/15823996#15823996

    And this video will help guide you through editing the file:
    http://www.youtube.com/watch?v=dW9aHlOIJUg
     

Share This Page