Safari 5.1 opens last website on launching.

Discussion in 'Mac OS X Lion (10.7)' started by seattle29, Jul 3, 2011.

  1. seattle29 macrumors member

    Joined:
    Dec 15, 2008
    #1
    How can I turn this feature off? I want Safari to open my homepage every time I launch it, but since upgrading to Lion (and Safari 5.1), then launching Safari opens the last-visited page before closing.

    I can't find the option anywhere in preferences??
     
  2. seattle29 thread starter macrumors member

    Joined:
    Dec 15, 2008
  3. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #4
    What do you SUGGEST when that does not work.

    My Safari 5.1 with LION still opens that last page instead of home page :(
     
  4. unobtainium macrumors 68000

    Joined:
    Mar 27, 2011
    #5
    I disabled Resume almost immediately, but I've noticed some apps still seem to be "resuming." I can't remember if they always did this! iPhoto is an example. It always opens up to the album I had selected before quitting. Is this the normal pre-Lion behaviour?
     
  5. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #6
    What Resume are you referring to?
     
  6. AdeFowler macrumors 68020

    AdeFowler

    Joined:
    Aug 27, 2004
    Location:
    England
    #7
    Don't quit Safari? ;)
     
  7. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #8
    Hare to do when you shut down Computer
     
  8. adztaylor macrumors 68000

    Joined:
    Aug 20, 2009
    Location:
    Preston, UK
    #9
    The only other option I can give you is to press cmd-option-q when quitting Safari or any other app you don't want to "resume"
     
  9. unobtainium macrumors 68000

    Joined:
    Mar 27, 2011
    #10
    Settings > General > Restore settings when quitting and re-opening apps.

    I have it unchecked but some apps still seem to "resume" (iPhoto is the only one I can replicate it on every time). But I can't remember if iPhoto always did that...
     
  10. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #11
    I just tried that - it does now work either
     
  11. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #12
    I do not see a RESUME - I see a Restore - as you can SEE I have it uncheccked
     

    Attached Files:

  12. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #13
    I may have found the SECRET setting - I changed the drop menu on APPLICATIONS to NONE --- See
    Now it seem to work and open to Home Page
     

    Attached Files:

  13. AdeFowler macrumors 68020

    AdeFowler

    Joined:
    Aug 27, 2004
    Location:
    England
    #14
    I'm not using Lion or Safari 5.1 yet, but on the Safari Features page it says:

    When you launch Safari in Lion or restart your Mac, Safari automatically restores the open windows and tabs from your last browsing session, so you can continue right where you left off. In Snow Leopard and Windows, you can choose to have Safari automatically restore your windows and tabs in the General pane of Safari preferences. When you use Resume, Safari won’t restore web pages viewed when Private Browsing is on.

    Also, holding down the shift key whilst launching an app overrides resume.
     
  14. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #15
    I am using LION and Safari 5.1 - this only happened after I upgraded
    yesterday to LION.

    ALL IS FIXED NOW - I POSTED the SECRET :p
     
  15. Eminemdrdre00 macrumors 6502a

    Eminemdrdre00

    Joined:
    May 10, 2008
    #16
    Can someone please upload Safari for Lion? I deleted it with App Cleaner thinking I could download a new copy from Apple.com, but they only offer Safari for Snow Leopard. There's a stupid bug that followed me from Snow Leopard to Lion, and I thought deleting Safari and reinstalling it might fix it.
     
  16. bernwa macrumors newbie

    Joined:
    Jul 24, 2011
    #17
    doesn't work

    I've tried all these solutions and my browser still goes to the last page I was on. This is especially irritating when doing web design and preview pages in Dreamweaver. Has anyone found a sure way to address this problem?
    Thanks!
     
  17. dcorban macrumors 6502a

    dcorban

    Joined:
    Oct 29, 2007
    #18
    Yes. My previous iPhoto 09 in Snow Leopard had this behaviour.
     
  18. PKGuy323 macrumors newbie

    Joined:
    Jan 25, 2008
    #19
    Nothing else worked...except for this! Thanks for the tip. It was very frustrating prior.
     
  19. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #20
    That is WHY I posted my find.

    I tried all the other things as well and none of them worked.

    I just finished rolling back to SNOW LEOPARD :):):)

    Goodbye to LION :(:mad::(
     
  20. RickyB macrumors regular

    Joined:
    Oct 28, 2007
    #21
    Try installing Safari for SL and then use Software Update to update it.
     
  21. diesel345 macrumors newbie

    diesel345

    Joined:
    Jul 25, 2011
    #22

    This seems to have worked for me as well. Thx, Dr. Hankz!!:)
     
  22. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #23
    Everyone thinks the check mark alone is enough.
    Not for me - I needed to disable Application memory.

    You are WELCOME.
     
  23. declandio macrumors 6502

    Joined:
    Apr 3, 2009
    Location:
    London, UK
    #24
    This feature annoyed me too.

    I found the following solution, you can use it to disable this behaviour for any application you like. If you want to turn it back on again, change the '0' in the command below to a '1'.

    Can't remember where I found the hint, but I think it was on macoshints website.

    "First you’ll need to know exactly which app you want to kill this feature on -- we’ll use Preview as an example, since it may not be desirable to have it restore documents in most cases. Fire up Terminal again and use the following command without quotes:

    “defaults write com.apple.Preview NSQuitAlwaysKeepsWindows -int 0”.

    For other applications, simply replace “Preview” with the name of the app -- when in doubt, visit your Preferences folder to confirm how the app name appears in the “com.apple.XXXX” file this is modifying."
     
  24. drhankz macrumors newbie

    Joined:
    Jul 21, 2011
    #25
    Thanks for that info - that is going into my LION OS Reference File - I'll save that one :)
     

Share This Page