Safari 5 - auto-fill URL deosn't work any more

Discussion in 'Mac Apps and Mac App Store' started by daver11, Jun 24, 2010.

  1. daver11 macrumors regular

    Joined:
    Feb 11, 2005
    Location:
    Phoenix, AZ
    #1
    I just noticed that when I start to type a URL in the URL field in Safari 5, it behaves differently than before.

    For example, before, if I typed "app" in the URL field and hit enter, it would automatically fill in "www.apple.com" and load the site. That's because Apple's site was the only site in my bookmark list that started with "app".

    Now when I type "app", it fills in "www.macnn.com" instead, because that site's DESCRIPTIVE TEXT begins "Apple, Macintosh...". So now, it assumes the letters I type in the URL bar are to help me find a site based on the "descriptive" text, instead of the actual URL text.

    I really hate this new behavior. I looked for an option or preference to change, but found nothing. Any of you know how to revert this behavior, or if it is even possible to do so?
     
  2. alienapp macrumors member

    Joined:
    Jan 5, 2010
    #2
    I don't like how safari 5 handles autofilling URL's too. But so far i don't think you can change that behavior.

    You might want to try using bookmarks for now. They are more efficient anyway.
     
  3. daver11 thread starter macrumors regular

    Joined:
    Feb 11, 2005
    Location:
    Phoenix, AZ
    #3
    I found an earlier posting about the same issue. There is no solution, as far as anyone knows. :(

    Thanks for the reply.
     
  4. daver11 thread starter macrumors regular

    Joined:
    Feb 11, 2005
    Location:
    Phoenix, AZ
    #4
    OK - one last comment. I just tried it again, and now it is behaving as before. I think Safari learned my preference. I suppose that is the best solution, after all. Better for Safari to have a small learning curve then to be locked into a particular method. :apple:
     

Share This Page