Safari 5 kills flash support on external displays?

Discussion in 'MacBook' started by yoyo5280, Aug 12, 2010.

  1. yoyo5280 macrumors 68000

    yoyo5280

    Joined:
    Feb 24, 2007
    Location:
    Melbourne, Australia & Bay Area
    #1
    I have a blackbook running 10.6.4 with a GMA 950 that I use dual monitors with. If I use the extended desktop mode, and drag a safari window with a flash player onto the external display it will freeze and become unusuable (can't interact with it). The audio will still play through the speakers, and dragging the window back onto the main display brings back the flash functionality.

    This is a fairly new problem, it never used to happen before.

    Any ideas why?

    UPDATE: It appears to be a Safari 5 issue. Anyone else experience it?
     
  2. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #2
    you would think that the graphics card is having some extreme problems running the extra monitor - especially given that flash is pretty intense. are these HD youtube videos, or the normal 480p etc ones?

    if you play any other mp4 movie from QT/iTunes does it still lag? does it still happen in mirrored mode? what happens if you lower the res on the extended desktop?
     
  3. yoyo5280 thread starter macrumors 68000

    yoyo5280

    Joined:
    Feb 24, 2007
    Location:
    Melbourne, Australia & Bay Area
    #3
    The videos are 360P on youchoob, shouldn't be too bad right? And they work in mirror mode.
    Playing an AVI with perian+QT and an .m4v work fine.
    Changing the resolution changed nothing. Me thinks its software?
     
  4. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #4
    yeh that should be fine, hardly intense at all. what is the CPU usage when its doing that? could be software, what happens if you try another website that still utilises flash?
     
  5. yoyo5280 thread starter macrumors 68000

    yoyo5280

    Joined:
    Feb 24, 2007
    Location:
    Melbourne, Australia & Bay Area
    #5
    CPU Usage: [​IMG]

    Problem happens on any webpage with flash.

    I just tried in Firefox and I DON'T have the issue :O
     
  6. DoFoT9 macrumors P6

    DoFoT9

    Joined:
    Jun 11, 2007
    Location:
    Singapore
    #6
    so it's safari then! how annoying. i wonder if its apparent for a number of other computers then with the same versions that you are running.
     
  7. yoyo5280 thread starter macrumors 68000

    yoyo5280

    Joined:
    Feb 24, 2007
    Location:
    Melbourne, Australia & Bay Area
    #7
    I haven't heard anything.

    That is frustrating.
     
  8. niga macrumors newbie

    Joined:
    Nov 25, 2010
    #8
    Hello.

    I think we have the same issue with safari (and i have on an old macbook core2duo, with acer 22'' external display).

    The fact is, flash videos freeze and stay black on external display. But if you put your flash videos in full screen you no longer have this problem.

    Maybe this new information can help to figure what's the problem and find a solution, because it's really annoying to have to put videos on fullscreen to see something else than a black rectangle.

    i noticed that because i've this issue for months (all was fine before). And i've done some tests, and it appear to be only a safari problem (no such things with chrome or firefox).

    P.S : I opened a thread on a french forum months ago, but nobody have a solution or know why we have this issue.
     

Share This Page