Safari 5 not working at all on my computer

Discussion in 'Mac Apps and Mac App Store' started by durtyfeet, Jun 8, 2010.

  1. durtyfeet macrumors newbie

    Joined:
    Apr 17, 2010
    #1
    I'm on OS 10.5.8. I just updated safari and java. Now when I open safari, I can not get a browser window to even open. Not by trying to open a new window or going into my history and opening the Apple page. This is really frustrating since I hate Firefox (WAY slower than safari has ever been for me) and now I can't even use Safari.

    Does anyone have any suggestions?
     
  2. Peace macrumors Core

    Peace

    Joined:
    Apr 1, 2005
    Location:
    Space--The ONLY Frontier
    #2
    Did you download the Snow Leopard version instead of the Leopard version ?
     
  3. durtyfeet thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #3
    nope, I believe that would be 10.6. I have audio software that I don't want risk on that OS yet.

    Or do you mean the version of Safari for snow leopard? I certainly hope not considering the way I got the download was through Software Update. I would think Apple would have the sense to work that out as they do other updates like this.
     
  4. grey head macrumors newbie

    Joined:
    Jun 8, 2010
    #4
    Me too

    I also upgraded to Safari 5 on my G5 PPC Macintosh running Leopard and it will not connect to apple's livepage or any saved bookmarks. Fortunately Firefox works well!

    I have emptied cache and reset Safari and even reinstalled without success.
     
  5. durtyfeet thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #5
    I think you and I are in the same boat, grey head.

    :mad::(
     
  6. DIABLOW macrumors member

    Joined:
    Jun 17, 2009
    #6
    I have the same problem after upgrading to safari 5. Before the upgrade my imac was very quick to download anything. By the way I am using fibre optic cable internet which is supposed to be very fast but now very slow like a snail. What have they done to safari?

    My imac is running with 10.6.3 snow leopard.
     
  7. dkgatling macrumors newbie

    Joined:
    Jun 9, 2010
    #7
    It seems that I have the same problem. I emptied the cash and reset Safari too, no luck. I also tried to re-download with the same result. Any other suggestions for a solution to this problem?
     
  8. durtyfeet thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #8
    On the phone with Apple now

    I'm on the phone now with someone from Apple. If I learn anything helpful, I'll post it.
     
  9. Hrududu macrumors 68020

    Hrududu

    Joined:
    Jul 25, 2008
    Location:
    Central US
    #9
    Thats interesting. I installed it on my 12" Powerbook and Cube running 10.5.8 and my TiBooks & a Clamshell running 10.4.11 and they all work fine. Wonder what the deal is?
     
  10. durtyfeet thread starter macrumors newbie

    Joined:
    Apr 17, 2010
    #10
    Just learned that the problem is with 3rd party plug-ins...but important ones such as Adobe. Therefore, you can go back to your original install discs and reinstall Safari (I'm not doing this) or just use Firefox until they come out with an update which I have been told will be in about a week. (This is the option I'm going with).

    Hope this helps someone.
     

Share This Page