Safari 5 Youtube Issues...

Discussion in 'Mac Apps and Mac App Store' started by dsalehipour, Jun 7, 2010.

  1. dsalehipour macrumors newbie

    Joined:
    Sep 18, 2008
    #1
    Hey guys,

    I was wondering if anyone else has been experiencing problems with youtube videos with Safari 5. Usually the problem occurs when the video is embedded in another website other than youtube. Such as www.toucharcade.com or articles in www.engadget.com. Also whenever I go to youtube, the top ad banner does not show.

    Also when I got to Youtube, the video thumbnails show but when I click to view any video the video box on the page just stays black.

    Anyone else have these problems?
     
  2. reptiledude4 macrumors member

    reptiledude4

    Joined:
    Apr 1, 2009
    #2
    I had the same problem, go here;
    http://www.youtube.com/html5
    ,and sign up for the HTML5, that fixed the problem for me. Maybe Apple nixed flash from Safari as well, lol.
     
  3. kasakka macrumors 68000

    Joined:
    Oct 25, 2008
    #3
    If you have ClickToFlash installed, you need to uninstall it and wait for them to update it to work with Safari 5. Might take a while because I assume they would want to move to using the Safari Extensions system.
     
  4. eXan macrumors 601

    eXan

    Joined:
    Jan 10, 2005
    Location:
    Russia
    #4
    I have C2F installed and YouTube runs just as it did in Safari 4 :confused:
     
  5. svkrzn macrumors regular

    Joined:
    Dec 8, 2009
    #5
    I too have some youtube problems with safari 5, but slightly different, for example this viceo in youtube: http://www.youtube.com/watch?v=CGNsJBirnck&feature=channel
    When i switch to Half screen view (HD) the side video bar covers half of the video and i can't understand if that safari 5 problem or youtube.
     
  6. jmbill macrumors member

    Joined:
    Dec 17, 2008
    #6
    I've also had problems on YouTube with Safari 5. I enlisted on their HTML5 Beta testing project and found that some pages were quite badly 'scrambled up' in both Safari 4 and Safari 5. Video download / embed links were under the video and thumbnails were breaking out of their grid. Seems like there were some CSS incompatibilities.

    In addition in Safari 5, HTML video's sometimes lock up for no apparent reason and my machine emits a really loud screaming sound like an alarm going off! Scared the hell out of me the first time it did it (even though system volume was turned right down low). Its happened twice now - both different videos.

    I uninstalled Click2Flash and Glims, but this issue seems unrelated to any plugins. Other browsers like Chrome and Firefox don't have any problems with YouTube, so I suspect this problem/s is related to Safari.
     
  7. gncor macrumors newbie

    Joined:
    Jun 9, 2010
    #7
    Safari bomb

    Like others, I downloaded Safari 5 yesterday only to have my system jam up. I was not able to log in to my computer. Even though my warranty was expired I called tech support and talked them into helping me. After speaking to two techs,, they told me that they have been advised to tell customers not to download v 5 now. I had to reset my password in order to get into the system and then reinstall Safari 4 from my Snow Leopard disc. This was the first (and Last) time I was so quick to download a new update.
     
  8. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #8
    I don’t have any Safari mods/extensions/plugins, just the latest Snow Leopard and Safari 5.

    Flash videos (especially YouTube) fail to play from time to time. I get a Black box, and not even a .flv or .m4v listing in the Activity window.

    Quitting and re-launching Safari seems to help.
     

Share This Page