Safari 7.0.5 stalling when loading web pages

Discussion in 'OS X Mavericks (10.9)' started by AdamA9, Jul 1, 2014.

  1. AdamA9 macrumors 6502a

    Joined:
    Feb 2, 2010
    #1
    Guys.

    I have an issue where Safari is stalling when loading web pages. I type an address, click a link or open Safari from new and the blue bar moves to about 20% and then stops. It stalls for about 20 seconds and then loads the web page. Sometimes it doesn't load at all and I need to swap from the TimeCapsule to my router.

    I am on Virgin Media with 152mbps so it cannot be to do with my internet speed. I don't know what it could be.

    Does anyone have an idea for how I can stop this, or speed up my browser?

    Many thanks
     
  2. chrisrosemusic1 macrumors 6502a

    chrisrosemusic1

    Joined:
    Jan 31, 2012
    Location:
    Northamptonshire, England
    #2

    You can try 'resetting' Safari:

    Safari>Reset Safari

    Then reboot the machine and see if clearing the cache etc helps.

    FYI, since updating, my Safari has actually been a little snappier.
     
  3. AdamA9 thread starter macrumors 6502a

    Joined:
    Feb 2, 2010
    #3
    Tried that. Also tried deleting the network, repairing permissions, changing the wifi channel and all with no joy.

    I get about 10 minutes use before it stops working. The blue bar will load a little way then stop. I have to disconnect and reconnect to get it working again.

    Very frustrating. FWIW my partners Air doesn't have this issue as far as I know.
     
  4. .X. macrumors member

    Joined:
    Mar 15, 2014
    #4
    You should try another browser, just to determine if it is a Safari issue or a underlying network or OS issue.
     
  5. ABC5S macrumors 68040

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
    #5
    Same thing happened to me, and nothing worked, and that included reinstalling clean the OS.

    Finally called my cable company, swapped out the modem for another, and most everything worked. Still, from time to time, when I clicked on Safari's icon, it would stick for around 20 to 30 seconds, than it would appear. Have no idea why.

    I have many favorites, but when clicking on them with the new modem, It would go right through most of the time, but on occasions it would stick for a while.....go figure

    New OS update 10.9.4 works a bit better
     
  6. leventozler macrumors 6502

    Joined:
    Feb 18, 2009
    #6
    Sounds like a DNS issue, Safari is trying to resolve or connect to the domain of a script/resource on a website, and continues to loading once it timeouts. It could also be IPv6 problem.
     
  7. xMClass macrumors 6502

    Joined:
    Mar 26, 2011
    Location:
    California
    #7
    I'm having the same exact issue. Blue loading bar goes to around 20% loaded and just hangs. Nothing happens for 30 seconds or more. I've tried everything already mentioned in this thread. It's not an internet issue since this doesn't occur in Chrome or Firefox. Tried using open DNS & Google DNS. Even disabled DNS prefetching and the issue still persists. Definitely a software problem.
     
  8. poorcody macrumors 6502

    poorcody

    Joined:
    Jul 23, 2013
    #8
    I've had this issue on and off since upgrading to Mavericks (first version).

    When it happens to you, try opening Terminal and doing a ping to www.google.com. I will often get dropped packets. I think it has to do with the now somewhat infamous ARP network problem... see:

    https://discussions.apple.com/thread/5483424?start=45&tstart=0

    and

    http://www.macstadium.com/blog/osx-10-9-mavericks-bugs/

    What's so frustrating about it is that it's hard to find a pattern to what causes it... it seems totally random.
     
  9. neteng101 macrumors 65816

    Joined:
    Jan 7, 2009
    #9
    I have seen this too - but it seems to happen only after the machine's been left alone for a while - either walking away for a few hours or in sleep mode overnight... I tried going back to 10.9.3 and redoing the 10.9.4 update, still no luck.

    Can't seem a way to soft reset/fix the problem, but a reboot will always clear it right up immediately. It affects everything, what you see in Safari is seen in Chrome, if you manually do a terminal telnet to an external port 80 and issue a get, you'll see the same kind of terrible lag/latency.

    For me though, it was all fine, until 10.9.4. Seems like maybe the wifi bug fix created new problems, but I'm not seeing widespread reports of this happening?
     
  10. kimjohnsson macrumors member

    Joined:
    Aug 13, 2013
    #10
    Hi all!

    I'm late to this, but anyway.

    My iMac has the same problem, kind of. Safari freezes after a while when my wife is using it on her account. Restarting Safari doesn't help, but logging in as me and then immediately loggin back as her fixes the problem. When I log back as her, Safari has already loaded the page which it got stuck on before I switched users. Works every time. Weird.

    I'm running the latest Yosemite Developer's preview.

    Cheers,

    Kim
     
  11. classypiano macrumors newbie

    Joined:
    Oct 27, 2014
    #11
    Same problem, but...

    I am experiencing the same problem with Safari. I've found on both my iMac and Macbook if I click on reload or the X in the address box after some time (maybe 10-30 secs), immediately the page I wanted comes up. Very annoying.
     
  12. QuarterSwede macrumors G3

    QuarterSwede

    Joined:
    Oct 1, 2005
    Location:
    Colorado Springs, CO
    #12
    I've got the same issue on Safari 6.0.5 in Lion (yeah, I need to upgrade to a new Mac). So if it's in software it's a fairly old bug.
     
  13. Rob.G macrumors 6502

    Rob.G

    Joined:
    Jan 17, 2010
    Location:
    NW Oregon
    #13
    Old thread, I know. But I have the same problem with Safari on Yosemite, on both my Mac Mini and my MacBook Pro. It's damn annoying. Does it more often than not.

    Rob
     
  14. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #14
    Try Onyx and clear out the caches.
     
  15. loopernow macrumors newbie

    loopernow

    Joined:
    Jun 6, 2015
    #15
  16. needhelpapple macrumors newbie

    Joined:
    Dec 5, 2015
    #16
    I have the exact issue that the original post describes. I have a rMBP. Basically, sometimes when I click a link or do a Google search, and the bar moves about 20% and stalls for 20 sec or so. For links, if I click it twice, it will load the page immediately (WTF?). For Google searches, sometimes it just completely refuses to search, period. This problem only happens every 3-4 times that I click a link or do a search.

    It is unrelated to the browser used (happens when I do stuff on both Chrome and Safari). I do not have this issue with my Windows laptop, which shares the same WiFi. Thus, I have narrowed it down to an issue that is not specific to the browser or my ISP. I think it has something to do with the OS hardware/firmware, as loopernow said. HOWEVER, for me, it was NOT fixable by using different DNS servers or disabling Safari prefetching. I am not in a position to update my router firmware or get a different router.

    Has anyone found a solution to this yet? People who posted in this thread before and had the issue, can you please provide some updates on your situation?
     
  17. cullers1984 macrumors newbie

    cullers1984

    Joined:
    Jan 5, 2016
    #17
    I have this problem with my 2015 Macbook. Did any of you guys find a solution?
     

Share This Page