Safari 8.0 doesn't remember Extensions

Discussion in 'OS X Yosemite (10.10)' started by Baklava, Jul 28, 2014.

  1. Baklava macrumors 6502a

    Baklava

    Joined:
    Feb 1, 2010
    Location:
    Germany
    #1
    Just wanted to know if I am the only one having the problem, that Safari 8.0 on Yosemite DP4 doesn't load installed Extensions. When I install an Extension, it works perfectly but after restarting Safari, they are gone. They are still inside the /Library/Safari/Extensions folder but when I want to use them, I need to install them again after every restart of Safari. I tried various methods like deleting pref files and so but still no fix.
     
  2. joedec macrumors 6502

    joedec

    Joined:
    Jul 25, 2014
    Location:
    Cupertino
    #2
    I installed AdBlock and DoNotTrackMe, both seem to be working fine on the Beta release (Version 8.0 (10538.46)

    ... Jeff
     
  3. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #3
    I am having the same issue since DP7. No solution found for me yet.
     
  4. kuwxman macrumors 6502

    kuwxman

    Joined:
    Jul 25, 2009
    Location:
    Olathe, KS
    #4
    They eff'd up Safari as a whole IMO. It was dumb to merge History AND website data into one clear button...with no way to change it. So now every time I clear my history, I have to log back in to every freaking website. No, no, NO. Change it back to how it was, Apple!

    I can't wait until Glims gets updated.
     
  5. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #5
    This is so frustrating. Has anyone solved this yet?
     
  6. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #6
    Again with the new update, GM Candidate, the issue still exists....
     
  7. ABC5S Suspended

    ABC5S

    Joined:
    Sep 10, 2013
    Location:
    Florida
  8. drew627 macrumors regular

    Joined:
    Jun 26, 2013
    #8
    +1
     
  9. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #9
    Did you ever fix this? I really don't want to re-install everything. If I make a new user, there is no issue. There must be some per user setting, cache, file, permission, or something that is preventing this from working.
     
  10. Baklava thread starter macrumors 6502a

    Baklava

    Joined:
    Feb 1, 2010
    Location:
    Germany
    #10
    I had that problem from DP4 all the way to GM3. Did a clean install of Yosemite (14A3899) via MAS yesterday and the problem is solved. I think it had something to do with the old preference files.
     
  11. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #11
    I tried everything I could think of. Nothing helped, although I am sure a clean full re-install would do it.

    I installed the Parallels Desktop App update to 10.1. It installed a safari extension. Now overtime I open Safari, it gives me this:

    "Your Safari Extensions have migrated. You can choose the extensions you want to use in Safari Preferences."

    If I click Open Preferences, it shows a list with only "Open in IE"....This gave me slight progress, If I now install a safari extension, it still goes away, however the Open in IE remains in the choices, but disabled. I manually edited Extensions.plist, and now my other extensions appear inside the list as well. (all disabled), now I can click to enable them...

    I am wondering if there is ANY way that Parallels caused this, or is it just a fluke? Now that I think of it, I upgrade to Parallels 10 around the same time this appeared.
     
  12. Baklava thread starter macrumors 6502a

    Baklava

    Joined:
    Feb 1, 2010
    Location:
    Germany
    #12
    I never had a message like that throughout the beta phase. I would suggest a clean install of OS X to get the extensions to work properly again. :)
     
  13. mikecwest macrumors 6502a

    mikecwest

    Joined:
    Jul 7, 2013
    #13
    Solved

    This was FINALLY solved! YES!!!

    I finally found the solution. I knew it had to be something very simple.

    Go into Keychain access, in the search box type "safari"

    It should have found "Safari Extensions List".

    Delete it.

    Open Safari, and one last time it will tell you that Safari Extensions have migrated. Now open your preferences, select your extensions.

    Close Safari, Open Safari, Rinse, Repeat....REJOICE. The problem is solved.:):)

    A special thanks to Carolyn Samit on Apple Support Communities!

    https://discussions.apple.com/thread/6620974
     

Share This Page